Bug 731963 - Asterisk 1.8.4.4-3 uses 100% cpu
Summary: Asterisk 1.8.4.4-3 uses 100% cpu
Keywords:
Status: CLOSED DUPLICATE of bug 658431
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: asterisk
Version: el6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-19 09:42 UTC by Ulf Tigerstedt
Modified: 2011-09-26 18:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-26 18:19:02 UTC


Attachments (Terms of Use)

Description Ulf Tigerstedt 2011-08-19 09:42:01 UTC
Description of problem:

Asterisk installed on a bare centos6 machine, with most things
in the config files removed (only one SIP and one IAX2 friend 

Version-Release number of selected component (if applicable):

asterisk-1.8.4.4-3.el6.x86_64


How reproducible:

Start asterisk?
Seems https://bugzilla.redhat.com/show_bug.cgi?id=716747 is related (but on Fedora 15)


The dialplan is simple:
wopr*CLI> dialplan show
[ Context 'app_queue_gosub_virtual_context' created by 'app_queue' ]
  's' =>            1. NoOp()                                     [app_queue]

[ Context 'default' created by 'pbx_config' ]
  '100' =>          1. Answer()                                   [pbx_config]
                    2. Ringing()                                  [pbx_config]
                    3. Dial(SIP/Abo-bt)                           [pbx_config]
  '3001' =>         1. Dial(IAX2/amphetamine/3001)                [pbx_config]
  '3002' =>         1. Dial(IAX2/amphetamine/3002)                [pbx_config]
  '3003' =>         1. Dial(IAX2/amphetamine/3003)                [pbx_config]
  '3004' =>         1. Dial(IAX2/amphetamine/3004)                [pbx_config]
  '3005' =>         1. Dial(IAX2/amphetamine/3005)                [pbx_config]
  '3006' =>         1. Dial(IAX2/amphetamine/3006)                [pbx_config]
  '3007' =>         1. Dial(IAX2/amphetamine/3007)                [pbx_config]
  '3008' =>         1. Dial(IAX2/amphetamine/3008)                [pbx_config]
  '3009' =>         1. Dial(IAX2/amphetamine/3009)                [pbx_config]
  '3010' =>         1. Dial(IAX2/amphetamine/3010)                [pbx_config]
  '3011' =>         1. Dial(IAX2/amphetamine/3011)                [pbx_config]
  '3012' =>         1. Dial(IAX2/amphetamine/3012)                [pbx_config]
  '3013' =>         1. Dial(IAX2/amphetamine/3013)                [pbx_config]
  '600' =>          1. Playback(demo-echotest)                    [pbx_config]
                    2. Echo()                                     [pbx_config]
                    3. Playback(demo-echodone)                    [pbx_config]
                    4. Goto(s,6)                                  [pbx_config]

[ Context 'parkedcalls' created by 'features' ]
  '700' =>          1. Park()                                     [features]

[ Context 'app_dial_gosub_virtual_context' created by 'app_dial' ]
  's' =>            1. NoOp()                                     [app_dial]

-= 18 extensions (23 priorities) in 4 contexts. =-

There is an IAX2 register to the amphetamine machine, one Grandstream SIP phone
registers to this box.

Comment 1 Jeffrey C. Ollie 2011-08-19 12:32:12 UTC
Please give 1.8.5.0, which is in epel-testing a try to see if it solves your problem.

Comment 2 Ulf Tigerstedt 2011-08-19 12:56:26 UTC
Thanks for the suggestion!

Sadly top shows:
  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
10402 root      20   0 1933m  21m 6032 S 100.0  0.4   2:15.80 asterisk          
 1752 root      20   0  252m 147m 9648 S  4.3  2.5  10:10.46 X                  
 1359 ntp       20   0 30048 1576 1128 S  0.3  0.0   0:00.03 ntpd              

No difference with the new version.

The switch is working great.. but the rest of the computer is somewhat sluggish.

Comment 3 Jeffrey C. Ollie 2011-09-20 20:45:09 UTC
If you add the following to /etc/asterisk/modules.conf does the CPU usage go down?

noload => chan_mgcp.so
noload => res_pktccops.so

If so you're probably running into bug #658431

Comment 4 Ulf Tigerstedt 2011-09-26 17:55:30 UTC
Confirmed, with MGCP and pktccops not loaded the problem goes away.

Comment 5 Jeffrey C. Ollie 2011-09-26 18:19:02 UTC

*** This bug has been marked as a duplicate of bug 658431 ***


Note You need to log in before you can comment on or make changes to this bug.