Bug 731993 - System name is overlapping on "LASTCHECKIN" text in left pane of Systems list
Summary: System name is overlapping on "LASTCHECKIN" text in left pane of Systems list
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Katello QA List
URL:
Whiteboard:
: 750836 (view as bug list)
Depends On:
Blocks: katello-blockers 761182
TreeView+ depends on / blocked
 
Reported: 2011-08-19 12:09 UTC by Sachin Ghai
Modified: 2013-03-27 20:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 761182 (view as bug list)
Environment:
Last Closed: 2012-04-27 00:32:42 UTC


Attachments (Terms of Use)
Attached screenshot of name overrunning the lastcheckin col (30.73 KB, image/png)
2011-08-24 19:20 UTC, Corey Welton
no flags Details
System name is overlapping on Lastcheckin text (17.31 KB, image/png)
2011-08-25 06:36 UTC, Sachin Ghai
no flags Details
sys name overlapping on Lastcheckin text has been fixed (39.50 KB, image/png)
2011-12-22 12:08 UTC, Sachin Ghai
no flags Details

Description Sachin Ghai 2011-08-19 12:09:07 UTC
Description of problem:
I registered a system from katello-cli. System was registered successfully. However when I checked the name of system in webUI, the name of system is overlapping on "LASTCHECKIN" text.

[root@dhcp201-207 katello]# katello -u admin -p admin system register --name=dhcp201-207.englab.pnq.redhat.com --org=ACME_Corporation --environment=rhel_test_env
Successfully registered system [ dhcp201-207.englab.pnq.redhat.com ]



Version-Release number of selected component (if applicable):
[root@dhcp201-207 katello]# rpm -qa | grep katello
katello-cli-0.1.4-1.git.63.54683c2.fc15.noarch
katello-0.1.64-1.git.0.0b431ff.fc15.noarch
[root@dhcp201-207 katello]# 


How reproducible:
always

Steps to Reproduce:
1. Register a system with FQDN from katello-cli, Like im my case: dhcp201-207.englab.pnq.redhat.com 
2. check the registered name in webUI

  
Actual results:
System name is overlapping on "LASTCHECKIN" text in left pane of Systems list 

Expected results:
text overlapping shouldn't be there on webUI.

Additional info:

Comment 1 Mike McCune 2011-08-24 19:16:35 UTC
Can we get a screenshot of this?

Comment 2 Corey Welton 2011-08-24 19:20:08 UTC
Created attachment 519696 [details]
Attached screenshot of name overrunning the lastcheckin col

Comment 3 Sachin Ghai 2011-08-25 06:36:26 UTC
Created attachment 519765 [details]
System name is overlapping on Lastcheckin text

Comment 4 Mike McCune 2011-11-02 14:40:16 UTC
*** Bug 750836 has been marked as a duplicate of this bug. ***

Comment 6 Tom McKay 2011-12-14 15:01:05 UTC
This is fixed. The name wraps in the table.

Comment 7 Tom McKay 2011-12-15 20:24:50 UTC
broken on firefox

Comment 8 Tom McKay 2011-12-15 22:50:56 UTC
commit d6e0a39d99cb3866eaec8cb3f841b7f392acf11b
Author: Tom McKay <thomasmckay@redhat.com>
Date:   Thu Dec 15 17:46:23 2011 -0500

    Bug 731993 - System name is overlapping on "LASTCHECKIN" text in left pane of Systems list
    https://bugzilla.redhat.com/show_bug.cgi?id=731993
    + Added ellipsis to name
    + Also added system status color icon, shortened height of rows, and changed the data displayed to OS, ARCH, and IP. (Note that this list of systems is due for an overhaul so the changes are cosmetic for the short term until that happens.)

Comment 9 Sachin Ghai 2011-12-22 12:07:37 UTC
Verified with latest katello build:

[root@dhcp201-162 certs]# rpm -qa | grep katello
katello-0.1.154-1.el6.noarch
katello-trusted-ssl-cert-1.0-1.noarch
katello-cli-common-0.1.30-1.el6.noarch
katello-glue-pulp-0.1.154-1.el6.noarch
katello-configure-0.1.46-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-glue-candlepin-0.1.154-1.el6.noarch
katello-all-0.1.154-1.el6.noarch
katello-repos-0.1.4-1.el6.noarch
katello-cli-0.1.30-1.el6.noarch
katello-glue-foreman-0.1.154-1.el6.noarch
katello-common-0.1.154-1.el6.noarch
katello-certs-tools-1.0.1-1.el6.noarch
katello-httpd-ssl-key-pair-1.0-1.noarch



The reported issue has been fixed. See the attachment in next comment.

Comment 10 Sachin Ghai 2011-12-22 12:08:34 UTC
Created attachment 549177 [details]
sys name overlapping on Lastcheckin text has been fixed


Note You need to log in before you can comment on or make changes to this bug.