Bug 73203 - RFE: non anti-aliased fixed font
RFE: non anti-aliased fixed font
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: fontconfig (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-31 15:36 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-03 12:10:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-31 15:36:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
On my laptop (IBM X22), every font available to the gnome-terminal (after a
default install) has hard-to-read characters.  I believe all available fonts are
anti-aliased, and it appears that the anti-aliasing is what causes the problem.
 Can we have "fixed misc" back, without anti-aliasing?  It would be nice to have
such a font available in gnome-terminal, instead of forcing use of xterm instead.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
n/a

Additional info:
Comment 1 Nalin Dahyabhai 2002-09-02 13:01:07 EDT
The terminal isn't capable of anti-aliasing bitmapped fonts, such as those
included in the bitmap-fonts package (lucidatypewriter).  My understanding of
"fixed" is that they're not so much a set of the same font at different sizes
(like lucidatypewriter) as they are a set of random faces at random sizes, so
including them in the bitmap-fonts package isn't desirable.

If necessary, you can pull the fonts from /usr/X11R6/lib/X11/fonts/misc,
decompress them, and place them in your ~/.fonts directory.  You'll then be able
to use them in any application, including gnome-terminal.
Comment 2 Need Real Name 2002-09-02 14:23:53 EDT
I made a ~/.fonts dir, copied the fonts/misc files to it and decompressed them,
but gnome-terminal->edit profile->font didn't list them.  As far as that goes,
xlsfonts shows all the misc-fixed fonts, but gnome-terminal doesn't.

In case I my original submission was confusing, I don't care about antialiasing
in my terminals -- I care about readability and size.  About size: if I can only
fit one terminal per virtual screen (workspace, whatever), then I'm going to be
very cross.  Unfortunately the fonts available through gnome-terminal's font
chooser only look good when they are too large.  For now xterm is good enough
(small and readable), but I'd hate to see the gnome-terminal replaced
permanantly by xterm.
Comment 3 Nalin Dahyabhai 2002-09-02 15:37:52 EDT
Try running "fc-cache ~/.fonts" to generate a fontconfig cache in the directory.
 (While this shouldn't be necessary, it can't hurt.)  You may need to restart
gnome-terminal (and because gnome-terminal uses factory mode by default, you'll
either need to shut down all of your gnome-terminal windows, or start one
manually with the --disable-factory flag).  Basically, once "fc-list" shows the
"Fixed" family of fonts, you'll be able to use them pretty much anywhere.
Comment 4 Owen Taylor 2002-09-03 12:10:45 EDT
I'm not really sure why this was assigned to fontconfig.

I'm certainly not going to change the default monospace font to be
a bitmap:

 A) A bitmap only looks good at certain sizes, 

 B) The appearance of the desktop as a whole is best if
    antialiasing/not-antialiasing is consistent between 
    all uses of text.

bug 68354 covers the request to add the misc-fixed fonts
to the bitmap fonts package.

Not sure went wrong with your attempt to install fonts by
copying them into ~/.fonts - I tried:

 mkdir ~/.fonts
 cd fonts
 cp /usr/X11R6/lib/X11/fonts/misc/7x13.pcf.gz .
 cp /usr/X11R6/lib/X11/fonts/misc/9x15.pcf.gz .
 gunzip *.gz

And I had a "Fixed" font with those two sizes. Maybe
you grabbed, say, the ISO8859-1 copies of the font
instead of the base unicode fonts?


Comment 5 Need Real Name 2002-09-03 13:12:37 EDT
I got the ~/.fonts stuff to work the second time around, after calling fc-cache
and mkfontdir.  I'm not sure that either of those additional steps were actually
necessry; perhaps I made some other mistake the first time around.  I certainly
didn't want you to change the default desktop font to -misc-fixed or some other
bitmap; I just wanted nice-looking fonts for my laptop that allowed 4
simultaneous terminals at 1024x768 (and they didn't need to be the default).

Given that bug 68354 suggests adding more fonts, I'm going to close this bug
with NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.