Bug 73208 - dhclient doesn't work with wlan-ng-driven prism-II mini-pci card
dhclient doesn't work with wlan-ng-driven prism-II mini-pci card
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-31 16:02 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-16 15:36:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-31 16:02:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
1) This is about dhclient.  dhcpcd is not part of null, and dhclient isn't
listed by bugzilla.  See bug 73206.

2) after starting wlan0 interface (actiontec prism II based modem/wireless combo
in IBM Thinkpad X22 9662-9DU), dhclient fails to get lease where dhcpcd succeeds:

[root@laptop root]# dhclient wlan0
Internet Software Consortium DHCP Client V3.0pl1
Copyright 1995-2001 Internet Software Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

/sbin/dhclient-script: configuration for wlan0 not found.
Listening on LPF/wlan0/00:20:e0:8a:53:bb
Sending on   LPF/wlan0/00:20:e0:8a:53:bb
Sending on   Socket/fallback
receive_packet failed on wlan0: Network is down
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
send_packet: Network is down

[root@laptop root]# ./dhcpcd wlan0


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.load wlan-ng modules, enable card and associate with base station:
  modprobe prism2_pci
  wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
  wlanctl-ng wlan0 lnxreq_autojoin ssid="$SSID" authtype="opensystem"

2.run dhclient wlan0, it will fail as described above.
3.run dhcpcd wlan0, it will succeed as above.
	

Additional info:

I'm happy to do any experiments, network dumps, etc.
Comment 1 Brian C. Huffman 2002-09-03 10:38:49 EDT
If you create a profile in /etc/sysconfig/network-scripts called ifcfg-wlan0,
this will work correctly.  This is what mine contains:

DEVICE=wlan0
BOOTPROTO=dhcp
ONBOOT=no
Comment 2 Elliot Lee 2003-01-13 13:00:22 EST
dhclient comes from the dhcp source package.
Comment 3 Daniel Walsh 2003-01-16 15:36:02 EST
I am closing this bug since a it was a setup problem.

Dan

Note You need to log in before you can comment on or make changes to this bug.