Bug 732187 - problem with filename parsing when a read modifier is used, e.g. 'test-18\:37.jpg[0]'
Summary: problem with filename parsing when a read modifier is used, e.g. 'test-18\:37...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ImageMagick
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-20 13:05 UTC by Oliver Henshaw
Modified: 2011-09-20 18:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-21 21:13:26 UTC


Attachments (Terms of Use)

Description Oliver Henshaw 2011-08-20 13:05:52 UTC
Description of problem:

I discovered after upgrading from f13 to f15 that digikam (actually kipi-plugins) no longer resizes my images. I tracked this due to it's use of 'convert' and was able to reproduce this on the command line:

$ convert -resize 1024x600 -verbose test-18\:37.jpg small/test-18\:37.jpg
test-18:37.jpg JPEG 1944x2592 1944x2592+0+0 8-bit DirectClass 2.651MB 0.130u 0:00.139
test-18:37.jpg=>small/test-18:37.jpg JPEG 1944x2592=>450x600 450x600+0+0 8-bit DirectClass 147KB 0.500u 0:00.240
$ convert -resize 1024x600 -verbose test-18\:37.jpg[0] small/test-18\:37.jpg
convert: no decode delegate for this image format `37.jpg' @ error/constitute.c/ReadImage/532.
convert: missing an image filename `small/test-18:37.jpg' @ error/convert.c/ConvertImageCommand/2949.

whereas both versions work if the file is named "test.jpg".


The problem arises due to the interaction of timestamps in the filename and the read frame modifier, '[0]', used by kipi-plugins. Further details can be found at http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=19215&sid=92d2d107379cfc06193f308603a89948&p=75054#p75066 - the bug is apparently fixed in ImageMagick-6.7.1-2, but I haven't been able to test it yet.


Version-Release number of selected component (if applicable):

By testing with old livecds, I discovered that the regression was introduced sometime between 6.5.8.10-7.fc13 and 6.6.4.1-14.fc14.


Additional info:

I haven't been able to test the fix yet - bug #715336 prevents me from backporting http://trac.imagemagick.org/changeset/4887 to F15 and I haven't yet tried building a newer ImageMagick to test in a F16/rawhide VM.

Comment 1 Pavel Alexeev 2011-08-21 20:12:24 UTC
Thank you for the bugreport, i can reproduce it.
I building new version with hope it may help.

Comment 2 Pavel Alexeev 2011-08-21 21:13:26 UTC
6.7.1-9 version built and problem solved by quick test.
http://koji.fedoraproject.org/koji/taskinfo?taskID=3290408

Comment 3 Oliver Henshaw 2011-09-18 19:56:34 UTC
I finally managed to test this in a F16 nightly image (it works! thanks) but I had to enable rawhide. Is this going to be built for F16?

Comment 4 Pavel Alexeev 2011-09-20 18:44:02 UTC
I think it will be. But really I don't known. You could ask it in ML.


Note You need to log in before you can comment on or make changes to this bug.