Bug 732266 - BUG: soft lockup - CPU#1
Summary: BUG: soft lockup - CPU#1
Keywords:
Status: CLOSED DUPLICATE of bug 794478
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-21 11:07 UTC by Sergei LITVINENKO
Modified: 2012-02-28 20:51 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-28 20:51:52 UTC


Attachments (Terms of Use)
f16 guest dmesg log. (61.36 KB, application/octet-stream)
2011-08-21 11:07 UTC, Sergei LITVINENKO
no flags Details

Description Sergei LITVINENKO 2011-08-21 11:07:07 UTC
Created attachment 519175 [details]
f16 guest dmesg log.

Description of problem:
A lot of error on console. System do not answer...

Version-Release number of selected component (if applicable):
kernel-3.0.1-3.fc16.i686.PAE
glibc-common-2.14.90-4.i686
glibc-2.14.90-4.i686
yum-3.4.3-4.fc16.noarch

How reproducible:
100%

Steps to Reproduce:
1. start f16 guest on KVM with '-smp 2' parameter
2. login into guest
3. run `yum clean all ; yum update`
  
Actual results:
A lot of error on console, system is busy and do not answer.

Expected results:
system work as expected


Additional info:

F16 is updated.

F16 is started by:

qemu-kvm -localtime -m 2047 -name Fedora-16 vmware -smp 2          \
         -drive file=fedor16-hd0.img,if=virtio,boot=on             \
         -drive file=fedor16-hd1.img,if=virtio,boot=off            \
         -net nic,macaddr=52:54:00:12:34:16,model=virtio -net tap  \
---
host is : Fedora release 14 (Laughlin) 
kernel  : 2.6.35.13-92.fc14.i686.PAE
kvm is  : qemu-system-x86-0.13.0-1.fc14.i686
Hardware: CPU - E6850, RAM - 6Go

Comment 1 Sergei LITVINENKO 2011-08-21 11:11:41 UTC
in case of '-smp 1' guest work as expected.

Source of script to start guest:

[sergeil@homedesk QEMU]$ cat run-fedor16.sh 
---
#! /bin/bash

export LC_ALL=C
export LANG=C

export VGA="-vga vmware"
export NET=virtio


qemu-kvm -localtime -m 2047 -name Fedora-16 $VGA -smp 2                 \
         -drive file=fedor16-hd0.img,if=virtio,boot=on                  \
         -drive file=fedor16-hd1.img,if=virtio,boot=off                 \
         -net nic,macaddr=52:54:00:12:34:16,model=$NET -net tap

---

Comment 2 Josh Boyer 2012-02-28 20:50:58 UTC
There are some known issues with KVM guests and soft lockups.  Work is on-going upstream to make the guest-host interaction better so the guest doesn't hit this.

For now, you can boot with nosoftlockup on the kernel command line.

See https://bugzilla.redhat.com/show_bug.cgi?id=794478#c4

Comment 3 Josh Boyer 2012-02-28 20:51:52 UTC
Also, given the host you reported against is F14 those fixes aren't going to make it to you at all.  I'm going to duplicate your bug to 794478, as only a future release will wind up fixing this issue.

*** This bug has been marked as a duplicate of bug 794478 ***


Note You need to log in before you can comment on or make changes to this bug.