Bug 794478 - [abrt] kernel: BUG: soft lockup - CPU#0 stuck for 185s! [lxdm-binary:744]
[abrt] kernel: BUG: soft lockup - CPU#0 stuck for 185s! [lxdm-binary:744]
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lxdm (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:f57e2dc9ceb911988e249f2ee01...
:
: 732266 (view as bug list)
Depends On:
Blocks: F17Beta-accepted/F17BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-02-16 17:39 EST by John Dulaney
Modified: 2014-06-18 05:06 EDT (History)
13 users (show)

See Also:
Fixed In Version: lxdm-0.4.1-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 13:42:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (4.53 KB, text/plain)
2012-02-16 17:39 EST, John Dulaney
no flags Details

  None (edit)
Description John Dulaney 2012-02-16 17:39:14 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        initrd=initrd0.img root=live:CDLABEL=Fedora-17-Alpha-x86_64-Live-LXDE rootfstype=auto ro liveimg quiet  rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
kernel:         3.3.0-0.rc3.git5.1.fc17.x86_64
reason:         BUG: soft lockup - CPU#0 stuck for 185s! [lxdm-binary:744]
time:           Thu 16 Feb 2012 05:30:32 PM EST

backtrace:      Text file, 4635 bytes
Comment 1 John Dulaney 2012-02-16 17:39:18 EST
Created attachment 563767 [details]
File: backtrace
Comment 2 Dave Jones 2012-02-16 18:05:46 EST
this is yet another case of softlockup not working in virtual environments.

boot with nosoftlockup for now, in absence of a better solution.
Comment 3 John Dulaney 2012-02-16 19:53:47 EST
Roger.
Comment 4 Dave Jones 2012-02-17 16:17:08 EST
there is work ongoing to make this problem a non-issue.

https://lkml.org/lkml/2011/12/5/490
Comment 5 John Dulaney 2012-02-17 16:46:37 EST
Okay, I think that there is something else going on here.  The CPU load actually does stay at close to 100%, even when there is nothing going on (from a user standpoint).  I have not seen CPU load drop below 80%, and it was only that low for a few moments.
Comment 6 dgod.osa 2012-02-28 03:46:28 EST
100% cpu likely a bug in lxdm, appeared in f17 because of new version of glib, have been fixed in upstream.
Comment 7 Josh Boyer 2012-02-28 15:51:52 EST
*** Bug 732266 has been marked as a duplicate of this bug. ***
Comment 8 John Dulaney 2012-02-28 22:50:43 EST
Changing component to lxdm and proposing for Beta NTH.
Comment 9 Christoph Wickert 2012-02-29 04:21:44 EST
I'll look at this later today.
Comment 10 John Dulaney 2012-02-29 15:41:23 EST
I don't know if it's happening with bare metal or not, but it seems to occur all the time in VMs.
Comment 11 Christoph Wickert 2012-02-29 16:57:39 EST
Yes, it does occur on bare metal, too. See bug 767861
Comment 12 John Dulaney 2012-02-29 19:28:04 EST
Cristoph:  Poke me if I can provide anything else or if you want me to test.
Comment 13 Adam Williamson 2012-03-02 13:25:12 EST
Discussed at 2011-03-02 blocker/NTH review meeting. Accepted as NTH due to significant impact on usability of LXDE desktop (100% CPU usage persists after logging in).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Christoph Wickert 2012-03-08 15:02:12 EST
dgod.osa, wha about the problem with switching VTs? Without this problem I would already have shipped an update.
Comment 15 dgod.osa 2012-03-08 20:18:13 EST
I don't see any desc of "about the problem with switching VTs", do you mean the lxdm default use the vt7? if this, modify the server command line just now.
Comment 16 Christoph Wickert 2012-03-15 16:06:26 EDT
I did modify the config to use vt1 by default - but then LXDM doesn't start on boot. It is started when I run /usr/sbin/lxdm manually though.
Comment 17 dgod.osa 2012-03-15 20:54:21 EDT
I have no problem,maybe you can give your lxdm rpm file.
Comment 19 dgod.osa 2012-03-21 07:58:37 EDT
I see you modify the vt1 in patch, but you don't apply the patch to rpm.
If you install or extract the rpm, view /etc/lxdm.conf in it, you will find it not changed.
Comment 20 Christoph Wickert 2012-03-21 08:29:51 EDT
That is correct, I don't apply the patch to change the configuration because if I do and change to vt1, lxdm will not start reliably. It will not start on boot of after changing the runlevel, however it will start if I call lxdm as root directly.

Did you try one of my packages?

Can anybody else confirm these packages work or don't with console set to vt1?
Comment 21 dgod.osa 2012-03-21 09:13:41 EDT
I try the lxdm-0.4.1-1.fc17.x86_64.rpm

I can boot with or without set to vt1.

if change runlevel in console with "init 5"
1 set to vt1, lxdm started at vt1 and screen chagned to vt1
2 not set to vt1, lxdm start at vt7 and screen not changed to vt7

I don't think there are any problem.
Comment 22 Christoph Wickert 2012-03-21 11:36:10 EDT
I tested a little further and I still have problems but they only happen with my external display attached. With only one display everything is fine, so I will push the updates ASAP.
Comment 23 Fedora Update System 2012-03-21 16:50:19 EDT
lxdm-0.4.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lxdm-0.4.1-1.fc17
Comment 24 Fedora Update System 2012-03-21 16:52:56 EDT
lxdm-0.4.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lxdm-0.4.1-1.fc16
Comment 25 Fedora Update System 2012-03-21 16:59:40 EDT
lxdm-0.4.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/lxdm-0.4.1-1.fc15
Comment 26 Fedora Update System 2012-03-21 21:55:36 EDT
Package lxdm-0.4.1-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lxdm-0.4.1-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4399/lxdm-0.4.1-1.fc16
then log in and leave karma (feedback).
Comment 27 John Dulaney 2012-03-22 14:24:12 EDT
Ok, it seems to be working here without huge cpu load.
Comment 28 Fedora Update System 2012-03-23 13:42:59 EDT
lxdm-0.4.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 29 Fedora Update System 2012-04-03 15:53:49 EDT
lxdm-0.4.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 30 Fedora Update System 2012-04-03 15:55:42 EDT
lxdm-0.4.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.