Bug 732287 - [abrt] blueman-1.21-7.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.66 was not provided by any .service files
[abrt] blueman-1.21-7.fc15: connection.py:630:call_blocking:DBusException: or...
Status: CLOSED DUPLICATE of bug 708055
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
abrt_hash:6de6785fdf560963fdcc0257696...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-21 12:00 EDT by william hanlon
Modified: 2012-04-26 16:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 16:53:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description william hanlon 2011-08-21 12:00:16 EDT
abrt version: 2.0.3
architecture:   i686
cmdline:        /usr/bin/python /usr/bin/blueman-applet
component:      blueman
executable:     /usr/bin/blueman-applet
kernel:         2.6.40-4.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        blueman-1.21-7.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.66 was not provided by any .service files
time:           Mon Aug 15 09:03:22 2011
uid:            500
username:       whanlon

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.66 was not provided by any .service files
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/blueman/ods/OdsManager.py", line 121, in on_stopped
:    server.Close()
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.66 was not provided by any .service files
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus._dbus.SessionBus (session) at 0x9807b0c>
:args: ()
:utf8_strings: False
:bus_name: dbus.UTF8String(':1.66')
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: dbus.ObjectPath('/org/openobex/server0')
:timeout: -1.0
:signature: ''
:dbus_interface: 'org.openobex.Server'
:message: <dbus.lowlevel.MethodCallMessage object at 0x958ff90>
:method: 'Close'

comment:
:Everytime I suspend my laptop, if I look at the bluetooth applet dropdown it says that bluetooth is on, but none of my devices are present.
:If I use the software switch in the dropdown to turn on and off bluetooth services, I still see the same thing. The only way I can get my devices to work again
:is to issue the command systemctl restart bluetooth.service, then sometimes it reports bluetooth manager has crashed. My devices always are visible though after
:restarting in this way.
Comment 1 william hanlon 2011-12-16 15:04:16 EST
This bug is still present in Fedora 16. Whenever I suspend my laptop, when I awaken it again, bluetooth functionality ceases. Each time I am forced to manually restart the bluetooth service via "systemctl restart bluetooth.service".

I have a Broadcom Bluetooth controller:

Bus 003 Device 002: ID 0a5c:2101 Broadcom Corp. Bluetooth Controller
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          224 Wireless
  bDeviceSubClass         1 Radio Frequency
  bDeviceProtocol         1 Bluetooth
  bMaxPacketSize0        64
  idVendor           0x0a5c Broadcom Corp.
  idProduct          0x2101 Bluetooth Controller
  bcdDevice            1.00
  iManufacturer           1 Broadcom Corp
  iProduct                2 Acer Module
  iSerial                 0 
  bNumConfigurations      1
Comment 2 Christoph Wickert 2012-04-26 16:53:53 EDT

*** This bug has been marked as a duplicate of bug 708055 ***

Note You need to log in before you can comment on or make changes to this bug.