Bug 73241 - RH Printer Config reports "error printing test page" without any diag output
Summary: RH Printer Config reports "error printing test page" without any diag output
Status: CLOSED DUPLICATE of bug 72177
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-printer   
(Show other bugs)
Version: null
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-01 15:43 UTC by J Mora
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-01 17:51:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description J Mora 2002-09-01 15:43:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
After properly setting up printer per tfox's Printer Config help, the RH Printer
Config simply reports 'There was an error printing test page'. /etc/printcap
remains empty, and a manual restart of lpd reports:

Starting lpd: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import printconf_backend
  File "/usr/share/printconf/util/printconf_backend.py", line 30, in ?
    _=gettext.gettext
NameError: name 'gettext' is not defined
No Printers Defined                                        [  OK  ]

Settings are persistent between application restarts, but it doesn't report
where the error occurred.



Version-Release number of selected component (if applicable):
printconf-gui 0.4.21

How reproducible:
Always

Steps to Reproduce:
1. Set up LOCAL printer on lp0
2. Apply changes
3. Attempt to print test page
	

Actual Results:  "There was an error trying to print the test page".

Expected Results:  Some sort of debugging info in /var/log, or dialog.

Additional info:

Lexmark Z51 on /dev/lp0 using LPD (selected using redhat-switch-printer).
Printer was not autodetected during setup, but I selected the lx5000 driver.
/dev/lp0 was detected, but doesn't autodetect model during setup.

Comment 1 J Mora 2002-09-01 17:51:29 UTC
Suggestion - Make CUPS the default printing system (found note in release notes
about this ;) and make the Cups Printer Configuration applet (cupsconfig) more
obvious. I had my printer running in 2 minutes after discovering cupsconfig.

Comment 2 Tim Waugh 2002-09-01 19:58:43 UTC
This error has been fixed since 0.4.22-1. 

*** This bug has been marked as a duplicate of 72177 ***


Note You need to log in before you can comment on or make changes to this bug.