Bug 732426 - During upgrade dbus restart kills X session
Summary: During upgrade dbus restart kills X session
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dbus
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-22 12:43 UTC by Zdenek Kabelac
Modified: 2013-03-06 04:07 UTC (History)
11 users (show)

Fixed In Version: dbus-1.4.10-3.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-28 05:34:02 UTC


Attachments (Terms of Use)

Description Zdenek Kabelac 2011-08-22 12:43:29 UTC
Description of problem:

Over a month I'm experiencing a problem with yum upgrade. Executing this within X session gnome-terminal is now 'killer' app - I do not know exact cause yet - but it has usually tragic results of killing my whole X session - which kill running yum transaction - which reveals some even more horrible bug in yum recovery, but that's for different bug report.

I'm suspecting systemd and it's restart operation for some dbus/ConsoleKit service. I'm not sure it's the bug within systemd - but I guess it's good starting point. (It might well be a bug of ConsoleKit - but since it's the same author, I'm postponing decisions here)

These are some last famous words of /var/log/message before killing my xsession:

Aug 20 22:57:41 linux yum[15495]: Updated: yum-utils-1.1.31-2.fc17.noarch
Aug 20 22:57:42 linux yum[15495]: Updated: sip-devel-4.12.4-1.fc17.x86_64
Aug 20 22:57:42 linux yum[15495]: Updated: git-gui-1.7.6-5.fc17.noarch
Aug 20 22:57:42 linux yum[15495]: Updated: git-svn-1.7.6-5.fc17.noarch
Aug 20 22:57:42 linux yum[15495]: Updated: git-email-1.7.6-5.fc17.noarch
Aug 20 22:57:42 linux yum[15495]: Updated: gitweb-1.7.6-5.fc17.noarch
Aug 20 22:57:42 linux yum[15495]: Updated: guilt-0.35-1.fc17.noarch
Aug 20 22:57:43 linux yum[15495]: Updated: 2:qemu-0.15.0-3.fc17.x86_64
Aug 20 22:57:43 linux console-kit-daemon[1033]: WARNING: Unable to open directory /usr/lib/ConsoleKit/run-seat.d: Error opening directory '/usr/lib/ConsoleKit/run-seat.d': No such file or directory
Aug 20 22:57:43 linux gnome-session[1197]: Gdk-WARNING: gnome-session: Fatal IO error 11 (Prostředek je dočasně nepřístupný) on X server :0.#012
Aug 20 22:57:43 linux dbus[709]: [system] Reloaded configuration
Aug 20 22:57:43 linux dbus[709]: [system] Reloaded configuration
Aug 20 22:57:45 linux console-kit-daemon[1033]: WARNING: Unable to open directory /usr/lib/ConsoleKit/run-seat.d: Error opening directory '/usr/lib/ConsoleKit/run-seat.d': No such file or directory
Aug 20 22:57:52 linux console-kit-daemon[1033]: WARNING: Unable to open directory /usr/lib/ConsoleKit/run-seat.d: Error opening directory '/usr/lib/ConsoleKit/run-seat.d': No such file or directory
Aug 20 22:58:29 linux console-kit-daemon[1033]: WARNING: Unable to open directory /usr/lib/ConsoleKit/run-seat.d: Error opening directory '/usr/lib/ConsoleKit/run-seat.d': No such file or directory
Aug 20 22:58:48 linux /usr/sbin/gpm[671]: *** info [daemon/processrequest.c(42)]: 
Aug 20 22:58:48 linux /usr/sbin/gpm[671]: Request on 6 (console 2)
Aug 20 22:59:16 linux /usr/sbin/gpm[671]: *** info [daemon/processrequest.c(42)]: 
Aug 20 22:59:16 linux /usr/sbin/gpm[671]: Request on 6 (console 2)



Version-Release number of selected component (if applicable):
systemd-33-1.fc16.x86_64
ConsoleKit-0.4.5-1.fc15.x86_64
yum-3.4.3-7.fc17.noarch


How reproducible:
Unpredictable during yum upgrade

Steps to Reproduce:
1. yum upgrade where lots of packages are updated in rawhide
2.
3.
  
Actual results:
Killed X session
Broken yum transaction

Expected results:
Flawless upgrade of packages while X session keeps running.

Additional info:

Comment 1 Zdenek Kabelac 2011-08-22 14:22:12 UTC
Looking at some other BZ - I've noticed I've got similar coredump from systemd
as in bug 732020  - I'm a bit wandering if this could be related somehow.

Comment 2 Bill Nottingham 2011-08-22 16:08:47 UTC
Are you sure dbus is getting restarted on upgrade? That's not supposed to happen.

Comment 3 Kay Sievers 2011-08-22 19:16:56 UTC
#732020 looks like a suspect for such an update problem.

But seems the new systemd stuff in dbus.spec needs to be fixed too. We are
currently looking into that.

Comment 4 Lennart Poettering 2011-08-22 19:29:40 UTC
This is a bug in the dbus package. It should not restart dbus, and should not enable dbus, and it should never disable it (it's statically enabled anyway). I'll fix this in dbus.

Comment 5 Fedora Update System 2011-08-22 20:37:27 UTC
dbus-1.4.10-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dbus-1.4.10-3.fc16

Comment 6 Zdenek Kabelac 2011-08-23 08:50:19 UTC
> dbus-1.4.10-3.fc16 has been submitted as an update for Fedora 16.
> https://admin.fedoraproject.org/updates/dbus-1.4.10-3.fc16

I've downloaded and manually installed this package (fc16 on my fc17 - I assume rebuild for rawhide should be made as well)

I've noticed few things:

1.) my gnome-session has been restarted in a way my whole desktop disappeared for several seconds (well maybe like 8 or more, I've nearly though it has died) and only background image was there. However then it has been freshly redrawn back.

2.) Then I've tried gnome-shell restart with  'Alt+F2 + r'  and I've ended with logout screen.

3.) After full X session I could restart gnome-shell without problems.

Comment 7 Fedora Update System 2011-08-23 13:30:43 UTC
Package dbus-1.4.10-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dbus-1.4.10-3.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/dbus-1.4.10-3.fc16
then log in and leave karma (feedback).

Comment 8 Zdenek Kabelac 2011-08-26 09:06:50 UTC
While doing another yum upgrade later - there still seems to be some issue related to this BZ.

It's really hard to give some more detailed info - so I'll describe symptoms.

During update I've been faced to black screen again - but this time the problem seemed to be that my X session console has been switched to some other probably uninitialized console screen - thus quite  Alt+F7 (where my X session is running) solved the problem and I've been back to my still running yum upgrade.

So it's far better - but still it's not ideal.

Comment 9 Zdenek Kabelac 2011-08-26 23:09:20 UTC
Marking as verified - as the crash no longer happens - but the solution is still not ideal - so keeping this BZ still open.

Comment 10 Fedora Update System 2011-08-28 05:33:56 UTC
dbus-1.4.10-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.