Bug 732465 - Lun's size is not updated after resize of the backing store LV and tgtd reload/targets update
Summary: Lun's size is not updated after resize of the backing store LV and tgtd reloa...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scsi-target-utils
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Andy Grover
QA Contact: Bruno Goncalves
URL:
Whiteboard:
: 770328 (view as bug list)
Depends On:
Blocks: 803608
TreeView+ depends on / blocked
 
Reported: 2011-08-22 14:40 UTC by Rami Vaknin
Modified: 2016-04-13 14:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-09 12:29:30 UTC


Attachments (Terms of Use)

Description Rami Vaknin 2011-08-22 14:40:47 UTC
Description of problem:
Lun's size is not updated after resize of the backing store LV and tgtd reload/targets update of target with 1 Lun

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 6.1 (Santiago)
scsi-target-utils-1.0.14-2.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Create target with 100GB backing store LV
2. lvresize the LV to 200GB
3. Reload tgtd + "tgt-admin --update ALL" (both passed successfully)
  
Actual results:
The LV resized successfully to 200GB, however the above LUN's size is still reported as 100GB

Expected results:


Additional info:

From /etc/tgt/targets.conf:

<target rvaknin_iscsi>
    <backing-store /dev/vg_openfiler03/rvaknin_iscsi>
        scsi_sn 547459
        scsi_id rvaknin_iscsi
    </backing-store>
</target>
===========================================================
lvs | grep rvaknin_iscsi:
rvaknin_iscsi  vg_openfiler03 -wi-ao 200.00g
===========================================================
From tgt-admin --show:

Target 84: rvaknin_iscsi
    System information:
        Driver: iscsi
        State: offline
    I_T nexus information:
        I_T nexus: 194
.
.
.
    LUN information:
        LUN: 0
            Type: controller
            SCSI ID: IET     00540000
            SCSI SN: beaf840
            Size: 0 MB, Block size: 1
            Online: Yes
            Removable media: No
            Readonly: No
            Backing store type: null
            Backing store path: None
            Backing store flags: 
        LUN: 1
            Type: disk
            SCSI ID: rvaknin_iscsi
            SCSI SN: 547459
            Size: 107374 MB, Block size: 512
            Online: Yes
            Removable media: No
            Readonly: No
            Backing store type: rdwr
            Backing store path: /dev/vg_openfiler03/rvaknin_iscsi
            Backing store flags: 
    Account information:
    ACL information:
        ALL

===========================================================
tgt-admin --update --tid=84:
Target --tid=84 is currently not configured
and does not exist in the config file - can't continue!

Comment 1 Rami Vaknin 2011-08-22 14:44:26 UTC
Regarding the "tgt-admin --update --tid=84", it of course should be "tgt-admin --update tid=84" (without the '--'), and it returns without error

Comment 3 RHEL Product and Program Management 2011-10-07 16:05:25 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 6 Ademar Reis 2016-04-13 14:51:13 UTC
*** Bug 770328 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.