This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 803608 - unexpected error from blockresize
unexpected error from blockresize
Status: CLOSED DUPLICATE of bug 770328
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.3
Unspecified Linux
medium Severity low
: rc
: ---
Assigned To: Eric Blake
Virtualization Bugs
: TestOnly, Tracking
Depends On: 732465 770328
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-15 04:48 EDT by dyuan
Modified: 2016-04-13 10:51 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-12 15:24:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dyuan 2012-03-15 04:48:22 EDT
Description of problem:
When I did the blockresize with the unsupported format or size, it will report undefined error.

Version-Release number of selected component (if applicable):
libvirt-0.9.10-5.el6
qemu-kvm-0.12.1.2-2.241.el6

How reproducible:
100%

Steps to Reproduce:
1.  # virsh blockresize rhel55 --path /var/lib/libvirt/images/RHEL-Server-5.5-32-virtio.qcow2 --size 3279425546
error: Failed to resize block device '/var/lib/libvirt/images/RHEL-Server-5.5-32-virtio.qcow2'
error: internal error unable to execute QEMU command 'block_resize': An undefined error has ocurred

2.  # virsh blockresize rhel62 --path /var/lib/libvirt/images/rhel62.img --size 527942500000
error: Failed to resize block device '/var/lib/libvirt/images/rhel62.img'
error: internal error unable to execute QEMU command 'block_resize': An undefined error has ocurred
 
Actual results:
error: internal error unable to execute QEMU command 'block_resize': An undefined error has ocurred


Expected results:
More clear error report.


Additional info:

The undefined error is from qemu-kvm, so it should depend on a qemu-kvm bug.
Comment 1 Osier Yang 2012-03-15 05:08:10 EDT
libvirt doesn't have work to do, the error message "An undefined error has
ocurred" is exactly what qemu returns, libvirt will report good error as
long as qemu return good one in this case, so you should reassign it to qemu-kvm.
Comment 2 Alex Jia 2012-03-15 05:32:17 EDT
It's a known qemu-kvm bug: https://bugzilla.redhat.com/show_bug.cgi?id=770328
Comment 3 dyuan 2012-03-15 22:18:05 EDT
I'll retested it from libvirt once the qemu-kvm bug is fixed.
Comment 7 Eric Blake 2013-07-12 15:24:00 EDT

*** This bug has been marked as a duplicate of bug 770328 ***

Note You need to log in before you can comment on or make changes to this bug.