Bug 732526 - Fails to reinstall if rhev-h has already been installed on the server
Summary: Fails to reinstall if rhev-h has already been installed on the server
Keywords:
Status: CLOSED DUPLICATE of bug 691679
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-22 19:28 UTC by Richard W.M. Jones
Modified: 2011-08-31 15:36 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-31 15:36:04 UTC


Attachments (Terms of Use)
Errors shown during install (991.42 KB, image/jpeg)
2011-08-22 19:30 UTC, Richard W.M. Jones
no flags Details
Possible root cause error from the log file (1.52 MB, image/jpeg)
2011-08-22 19:31 UTC, Richard W.M. Jones
no flags Details
ovirt.log (44.48 KB, text/plain)
2011-08-22 20:20 UTC, Richard W.M. Jones
no flags Details
/var/log/messages (4.79 KB, text/plain)
2011-08-22 20:21 UTC, Richard W.M. Jones
no flags Details
reinstall param (199.10 KB, image/png)
2011-08-23 11:09 UTC, Ying Cui
no flags Details
1.jpg (33.46 KB, image/jpeg)
2011-08-24 09:52 UTC, Richard W.M. Jones
no flags Details
2.jpg (47.00 KB, image/jpeg)
2011-08-24 09:52 UTC, Richard W.M. Jones
no flags Details
3.jpg (46.45 KB, image/jpeg)
2011-08-24 09:52 UTC, Richard W.M. Jones
no flags Details
4.jpg (36.93 KB, image/jpeg)
2011-08-24 09:53 UTC, Richard W.M. Jones
no flags Details
5.jpg (35.41 KB, image/jpeg)
2011-08-24 09:53 UTC, Richard W.M. Jones
no flags Details
6.jpg (61.21 KB, image/jpeg)
2011-08-24 09:53 UTC, Richard W.M. Jones
no flags Details
7.jpg (55.42 KB, image/jpeg)
2011-08-24 09:54 UTC, Richard W.M. Jones
no flags Details
dmesg (40.30 KB, text/plain)
2011-08-24 09:54 UTC, Richard W.M. Jones
no flags Details
lvs (861 bytes, text/plain)
2011-08-24 09:55 UTC, Richard W.M. Jones
no flags Details
/var/log/messages (4.00 KB, text/plain)
2011-08-24 09:55 UTC, Richard W.M. Jones
no flags Details
pvs (745 bytes, text/plain)
2011-08-24 09:55 UTC, Richard W.M. Jones
no flags Details
/tmp/ovirt.log (43.51 KB, text/plain)
2011-08-24 09:56 UTC, Richard W.M. Jones
no flags Details
/var/log/ovirt.log (46.40 KB, text/plain)
2011-08-24 09:56 UTC, Richard W.M. Jones
no flags Details
vgs (595 bytes, text/plain)
2011-08-24 09:57 UTC, Richard W.M. Jones
no flags Details
reinstall.log (75.92 KB, text/plain)
2011-08-25 08:11 UTC, Ying Cui
no flags Details

Description Richard W.M. Jones 2011-08-22 19:28:03 UTC
Description of problem:

I tried to reinstall RHEV-H (to fix bug 732515).  I had already
installed RHEV-H to the hard disk once.  The reinstall failed.  I'll
attach some screenshots to this bug to show the errors.

Version-Release number of selected component (if applicable):

rhev-hypervisor 6.2-0.12.1.el6

How reproducible:

I tried the reinstall twice.  It failed in the same way both
times.

Steps to Reproduce:
1. Install RHEV-H to hard disk.
2. Reinstall RHEV-H a second time.
3.
  
Actual results:

Fails to reinstall.

Expected results:

Should be able to reinstall over the top of an existing installation.

Additional info:

See screenshots.

Comment 1 Richard W.M. Jones 2011-08-22 19:30:21 UTC
Created attachment 519336 [details]
Errors shown during install

Comment 2 Richard W.M. Jones 2011-08-22 19:31:16 UTC
Created attachment 519338 [details]
Possible root cause error from the log file

Comment 4 Richard W.M. Jones 2011-08-22 20:19:44 UTC
ssh does not work inside rhev-h.  However this is a neat
trick to fix it:

  script -q /dev/null -c "ssh command"

Comment 5 Richard W.M. Jones 2011-08-22 20:20:13 UTC
Created attachment 519344 [details]
ovirt.log

Comment 6 Richard W.M. Jones 2011-08-22 20:21:00 UTC
Created attachment 519345 [details]
/var/log/messages

Comment 7 Richard W.M. Jones 2011-08-22 21:24:10 UTC
After doing dd if=/dev/zero of=/dev/sda and rebooting
I was able to reinstall RHEV-H.  So it does seem to be
something about the old installation / partitions
confusing the installer.

Comment 8 Mike Burns 2011-08-22 21:35:46 UTC
(In reply to comment #7)
> After doing dd if=/dev/zero of=/dev/sda and rebooting
> I was able to reinstall RHEV-H.  So it does seem to be
> something about the old installation / partitions
> confusing the installer.

I'm not sure what the exact issue is here, but you can force the cleanup using command line options:

storage_init=/dev/sda reinstall

This should boot back to the main installation screen.

Comment 10 Ying Cui 2011-08-23 11:01:11 UTC
> I'm not sure what the exact issue is here, but you can force the cleanup using
> command line options:
> 
> storage_init=/dev/sda reinstall
> 
> This should boot back to the main installation screen.

with the storage_init=/dev/sda reinstall params,
1. first remove the exited partitions
2. create the new partitions for root/rootbackup etc by auto install.
3. after auto installation,there display the installation screen, just 'Quit' can be operated.
4. Press F2, there display error.

******************
0
Traceback (most recent call last):
File "/user/libexec/ovirt-config-installer", line 751, in start
menu_choice=self.menu_list.current()
File
"/usr/lib64/python2.6/site-packages/snack/py", line 183, in current KeyError: 0

******************

Need to be clear,
1. which step should boot back to the main installation screen? after removing the existed partition? or after auto installation?

Comment 11 Ying Cui 2011-08-23 11:09:33 UTC
Created attachment 519437 [details]
reinstall param

Comment 12 Mike Burns 2011-08-23 11:19:51 UTC
Joey,  can you look at the error when re-install is specified?

Having it not work with reinstall is a bug.  Booting with reinstall and storage_init triggers the cleanup in dracut.  Then after dracut finishes, it should boot to the regular install page with an Install option.  That the install option is missing is a bug. 

you can boot with "storage_init=/dev/sda uninstall" and that will do a complete wipe of all disks listed in storage_init and then reboot the machine.  You'll have to choose the pxe option again, or choose to boot from CD again in this case which is why I didn't offer it the first time

Comment 13 Joey Boggs 2011-08-23 14:32:38 UTC
the keyerror seems like an inconsistency in determining hostvg status and it cant present the right install/upgrade option leaving it blank(causing the keyerror). Can you run through the steps again? Once it fails, rerun the reinstall immediately to see if its just caching something? If it succeeds it must be holding onto some lvm info still. If it fails can you run through and snap a shot of the usual {pv,vg,lv}scan commands? Unable to reproduce with a vm installation but will try on real hardware and post those results as well.

Comment 15 Richard W.M. Jones 2011-08-24 09:04:59 UTC
HP ProLiant microserver.

One SATA drive which is:
scsi 2:0:0:0: Direct-Access     ATA      VB0250EAVER      HPG0 PQ: 0 ANSI: 5
sd 2:0:0:0: [sda] 488397168 512-byte logical blocks: (250 GB/232 GiB)

Can you be much more explicit about what exactly you want
me to do?  I've already been through the reinstall twice and
it failed to reinstall both times.  Each time I had to go to
the shell and dd zeroes over the first 100MB and reboot in
order to clear the problem.

Comment 16 Richard W.M. Jones 2011-08-24 09:51:34 UTC
I've gone through the install process another time.
RHEV-H was previously installed.  I PXE-booted RHEV-H
and followed the steps.  Same failure this time,
RHEV-H failed to (re-)install over the existing image.

After the failed installation, I pressed F2 to get a shell, and
captured the following information which I will attach to this bug:

1-7.jpg: pictures showing installation process
dmesg.txt: output of 'dmesg' command after failed installation
lvs.txt: output of 'lvs' command
messages: contents of /var/log/messages
pvs.txt: output of 'pvs' command
tmp-ovirt.log: contents of /tmp/ovirt.log
var-log-ovirt.log: contents of /var/log/ovirt.log
vgs.txt: output of 'vgs' command

It's not likely I will be able to reproduce this bug in future
because I need to install RHEL on this hardware and use it as
a server.

Comment 17 Richard W.M. Jones 2011-08-24 09:52:10 UTC
Created attachment 519582 [details]
1.jpg

Comment 18 Richard W.M. Jones 2011-08-24 09:52:34 UTC
Created attachment 519583 [details]
2.jpg

Comment 19 Richard W.M. Jones 2011-08-24 09:52:55 UTC
Created attachment 519584 [details]
3.jpg

Comment 20 Richard W.M. Jones 2011-08-24 09:53:14 UTC
Created attachment 519585 [details]
4.jpg

Comment 21 Richard W.M. Jones 2011-08-24 09:53:33 UTC
Created attachment 519586 [details]
5.jpg

Comment 22 Richard W.M. Jones 2011-08-24 09:53:57 UTC
Created attachment 519587 [details]
6.jpg

Comment 23 Richard W.M. Jones 2011-08-24 09:54:18 UTC
Created attachment 519588 [details]
7.jpg

Comment 24 Richard W.M. Jones 2011-08-24 09:54:38 UTC
Created attachment 519589 [details]
dmesg

Comment 25 Richard W.M. Jones 2011-08-24 09:55:01 UTC
Created attachment 519590 [details]
lvs

Comment 26 Richard W.M. Jones 2011-08-24 09:55:27 UTC
Created attachment 519591 [details]
/var/log/messages

Comment 27 Richard W.M. Jones 2011-08-24 09:55:49 UTC
Created attachment 519592 [details]
pvs

Comment 28 Richard W.M. Jones 2011-08-24 09:56:28 UTC
Created attachment 519594 [details]
/tmp/ovirt.log

Comment 29 Richard W.M. Jones 2011-08-24 09:56:51 UTC
Created attachment 519595 [details]
/var/log/ovirt.log

Comment 30 Richard W.M. Jones 2011-08-24 09:57:11 UTC
Created attachment 519596 [details]
vgs

Comment 31 Richard W.M. Jones 2011-08-24 09:59:45 UTC
PXE configuration.  This config was generated by
rhevh-iso-to-pxeboot and the only thing I have changed
were the paths to the vmlinuz and initrd files.

----------

DEFAULT pxeboot
TIMEOUT 20
PROMPT 0
LABEL pxeboot
        KERNEL rhev-hypervisor-6.2-0.12.1.el6-x86-64/vmlinuz0
        APPEND rootflags=loop initrd=rhev-hypervisor-6.2-0.12.1.el6-x86-64/initrd0.img root=live:/rhev-hypervisor.iso rootfstype=auto ro liveimg nomodeset check rootflags=ro crashkernel=512M-2G:64M,2G-:128M elevator=deadline processor.max_cstate=1 install quiet rd_NO_LVM rhgb rd_NO_LUKS rd_NO_MD rd_NO_DM 
ONERROR LOCALBOOT 0

Comment 33 Ying Cui 2011-08-25 08:10:58 UTC
(In reply to comment #12)
> Joey,  can you look at the error when re-install is specified?
> 
> Having it not work with reinstall is a bug.  Booting with reinstall and
> storage_init triggers the cleanup in dracut.  Then after dracut finishes, it
> should boot to the regular install page with an Install option.  That the
> install option is missing is a bug. 
> 
> you can boot with "storage_init=/dev/sda uninstall" and that will do a complete
> wipe of all disks listed in storage_init and then reboot the machine.  You'll
> have to choose the pxe option again, or choose to boot from CD again in this
> case which is why I didn't offer it the first time

Hi Joey,
   Check this issue with latest build 6.2-0.14. When booting with storage_init and reinstall params, the behavior is not correct that it do NOT boot to regular install page,it start to auto installation, at the end there display the UI page. Press F2, there display error. pls check the output log info.

Attached: reinstall.log

   The phenomenon with the bug description is not the same as comment #10, I will separate the new bug for comment #10 to make this issue more clearly.

Thanks
Ying

Comment 34 Ying Cui 2011-08-25 08:11:57 UTC
Created attachment 519783 [details]
reinstall.log

Comment 35 Ying Cui 2011-08-25 10:50:00 UTC
I open a new bug to trace the detail issue for comment #10 and comment #33

https://bugzilla.redhat.com/show_bug.cgi?id=733274

Comment 36 Joey Boggs 2011-08-26 02:27:38 UTC
Ying,

I think we're clear on this bug now then, the original issue was narrowed down to a dirty install, and the secondary issue with autoinstall and the firstboot menu at the same time you found was moved to a new bug. Are there any outstanding issues here still? If not we can close this one out

Comment 37 Mike Burns 2011-08-31 15:36:04 UTC
Closing since there is no fix here.

*** This bug has been marked as a duplicate of bug 691679 ***


Note You need to log in before you can comment on or make changes to this bug.