Bug 733274 - Booting rhevh with reinstall parameter, it does not work properly
Summary: Booting rhevh with reinstall parameter, it does not work properly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 10:47 UTC by Ying Cui
Modified: 2016-04-26 13:33 UTC (History)
7 users (show)

Fixed In Version: ovirt-node-2.0.2-0.5.git83340dd.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:26:35 UTC


Attachments (Terms of Use)
reinstall.log (75.92 KB, text/plain)
2011-08-25 10:50 UTC, Ying Cui
no flags Details
Patch (1.68 KB, patch)
2011-08-25 13:58 UTC, Mike Burns
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description Ying Cui 2011-08-25 10:47:07 UTC
Separate this issue from bug #732526.

Description:
  booting rhevh6.2 with reinstall+storage_init params, the behavior is not correct that it do NOT boot to regular install page,it start to auto installation, at the end there display the installation screen, just 'Quit'.Press F2, there display error.
  So reinstall param behavior is not correct.

Test build
6.2-0.14

Test steps
1. boot rhevh with reinstall + storage_init params.
2. wipe LVM PV successful.
3. partition start and process auto installation.

Actual result:
 after wiping LVM PV..., partition start and auto install rhevh. at the end there display the installation screen. Press F2, there display error.

************errors in TUI******
0
Traceback (most recent call last):
File "/user/libexec/ovirt-config-installer", line 751, in start
menu_choice=self.menu_list.current()
File
"/usr/lib64/python2.6/site-packages/snack/py", line 183, in current KeyError: 0

*******************************

Expected result:
 Booting with reinstall and storage_init triggers the cleanup in dracut.  Then after dracut finishes, it should boot to the regular install page with an Install option.

Comment 1 Ying Cui 2011-08-25 10:50:32 UTC
Created attachment 519809 [details]
reinstall.log

Comment 3 Mike Burns 2011-08-25 12:26:55 UTC
This is actually an issue only with PXE infrastructure that does IPAPPEND.  It adds BOOTIF=XX:XX:XX:XX:XX:XX to the pxe commandline

BOOTIF in conjunction with storage_init will trigger autoinstall which is not the desired functionality here.

Comment 4 Mike Burns 2011-08-25 12:30:43 UTC
Proposed change:  

update dracut plugin to remove HostVG if uninstall|reinstall|firstboot are provided
dracut plugin will still clean any devices listed in storage_init, but storage_init should be reserved for autoinstall use cases only.

Comment 5 Mike Burns 2011-08-25 13:58:13 UTC
Created attachment 519856 [details]
Patch

Comment 6 Mike Burns 2011-08-25 14:08:31 UTC
Testing:

boot with just reinstall/uninstall/firstboot options
should clean up HostVG devices

boot with reinstall/firstboot/uninstall and storage_init=<device_list>
should clean all devices in device_list and all devices with HosVG.  Try with both storage_init=hostvg devices and storage_init != hostvg devices

Comment 8 Mohua Li 2011-09-08 09:17:34 UTC
rhev-hypervisor 6.2-0.15

install with "storage_init=/dev/vda reinstall" could wipe the device correctly, but after finished create all the lv, still boot to a blank ovirt-node TUI menu, so this is not fixed,

Comment 9 Alan Pevec 2011-09-08 09:55:38 UTC
(In reply to comment #8)
> rhev-hypervisor 6.2-0.15
> 
> install with "storage_init=/dev/vda reinstall" could wipe the device correctly,
> but after finished create all the lv, still boot to a blank ovirt-node TUI
> menu, so this is not fixed,

This was then default boot option from rhevh media and not from installed disk i.e. with "install" boot parameter.

But I agree that this is still suboptimal, originally reported exception in menu_choice=self.menu_list.current() should be avoided, at least so that <Quit> button works and with the appropriate error messages instead of the blank screen.

Comment 10 Joey Boggs 2011-09-08 18:37:23 UTC
not able to produce this but maybe I'n not taking the right steps. After install and reboot back into first boot I get the right " reinstall $version " option

Are these steps right?
- install via tui booting with "reinstall storage_init=/dev/vda" (storage_init option not necessary anymore)
- run though install
- reboot to firstboot again

Comment 11 Alan Pevec 2011-09-08 19:34:40 UTC
(In reply to comment #10)
> not able to produce this but maybe I'n not taking the right steps.

I could reproduce it when I had Root partition on disk where installation failed for some reason. You could simulate it by booting into rescue, mounting Root partition and removing "version" file.

In this case display something like "Invalid installation, please reboot from media and choose Reinstall option" and enable <Quit> button.

Comment 15 errata-xmlrpc 2011-12-06 19:26:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.