Bug 73268 - M-x man displays improperly
M-x man displays improperly
Status: CLOSED DUPLICATE of bug 71646
Product: Red Hat Public Beta
Classification: Retired
Component: emacs (Show other bugs)
null
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-01 22:39 EDT by Jay Berkenbilt
Modified: 2015-01-07 19:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-01 22:39:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Berkenbilt 2002-09-01 22:39:03 EDT
Description of Problem:

M-x man dispays control codes in addition to face changes when displaying manual
pages.

Version-Release number of selected component (if applicable):

emacs-21.2-17

For what it's worth, this happens in (null) with the current pretest release of
emacs (21.2.90, still....)

How Reproducible:

always

Steps to Reproduce:
1. M-x man RET ls RET

Actual Results:

You see something like this:

LS(1)                            User Commands                           LS(1)

NAME
       ls - list directory contents

SYNOPSIS
       ls ^[[22m[^[[4mOPTION^[[24m]... [^[[4mFILE^[[24m]...


Expected Results:

You should see something closer to this:

LS(1)                          FSF                          LS(1)

NAME
       ls - list directory contents

SYNOPSIS
       ls [OPTION]... [FILE]...



Additional Information:
	
I'm a bit confused as to what's causing this.  Perhaps a change in groff output?
 I have not investigated it or reported it to bug-gnu-emacs (or the pretest
list) because it appears to be a RedHat issue.

This does not happen on RedHat 7.3.  I don't think it happened on Limbo either
because I'm sure I would have noticed it as I use M-x man often.  (Both my Limbo
systems are now running (null), so I can't check.)

This happens even with

LANG=C emacs -q --no-site-file

so, at first glance, it does not appear to be locale-related.  This does not
happen with emacs 21.2.90 compiled on (null) and run on RedHat 7.3 (with
/usr/lib nfs-mounted from a (null) system in its LD_LIBRARY_PATH).

Please let me know if you need me to further investigate.
Comment 1 Trond Eivind Glomsrxd 2002-09-03 11:24:21 EDT

*** This bug has been marked as a duplicate of 71646 ***

Note You need to log in before you can comment on or make changes to this bug.