Bug 732692 - Get correct version of python-xattr included in Fedora for glance image caching
Get correct version of python-xattr included in Fedora for glance image caching
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openstack-glance (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Russell Bryant
Fedora Extras Quality Assurance
:
Depends On: 781838 782622
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-23 06:26 EDT by Mark McLoughlin
Modified: 2012-01-25 16:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-25 16:03:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
markmc: fedora_requires_release_note-
markmc: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2011-08-23 06:26:03 EDT
Fedora's pyxattr package packages this upstream:

http://pyxattr.sourceforge.net/

For its image caching support (which is disabled by default), glance requires this version:

http://pypi.python.org/pypi/xattr

The only complication is that our pyxattr includes these lines:

  #python-xattr name was used in DAG repository
  Provides:       python-xattr = %{version}-%{release}
  Obsoletes:      python-xattr <= %{version}-%{release}
Comment 1 Marcin Zajaczkowski 2011-08-23 16:24:39 EDT
I think we can safely remove those lines - DAG's repository was merged into rpmfusion in 2005 and doesn't provide that package for Fedora 10+ anymore.

Nevertheless there would be still a problem to provide xattr (pypi) as python-xattr. I didn't make a test, but that new package could try to replace pyxattr (has higher version number) in case of the systems that are not updated to pyxattr without mentioned lines.

But maybe there is some clever solution which allows to mitigate that problem.
Comment 2 Russell Bryant 2012-01-04 18:50:38 EST
Would this be an acceptable approach?

1) Update pyxattr to remove the Provides/Obsoletes lines for python-xattr.  This would be in version X of the pyxattr package.

2) Create a new package, python-xattr, which Conflicts with pyxattr <= X.
Comment 3 Marcin Zajaczkowski 2012-01-04 19:24:39 EST
Haven't tested that solution, but seems logical for me.

> 2) Create a new package, python-xattr, which Conflicts with pyxattr <= X.

Did you mean "pyxattr < X"?
Comment 4 Mark McLoughlin 2012-01-05 02:52:06 EST
The question is whether, given that pyxattr is already installed, yum's depsolver will take a transaction which includes python-xattr and resolve that to include latest pyxattr. We're assuming it will look at latest python-xattr, see the Conflicts and resolve those by updating pyxattr.

One thing that might happen is that 'yum install python-xattr', or 'yum install foo' where foo has 'Requires: python-xattr', would not result in newer python-xattr being installed because older pyxattr is already installed. That's not a big problem, though, we would just make sure that glance has 'Requires: python-xattr >= 0.6.2'

So, yes - I think it'll work too :)
Comment 5 Russell Bryant 2012-01-05 08:29:00 EST
(In reply to comment #3)
> Haven't tested that solution, but seems logical for me.
> 
> > 2) Create a new package, python-xattr, which Conflicts with pyxattr <= X.
> 
> Did you mean "pyxattr < X"?

Yes.  :-)
Comment 6 Russell Bryant 2012-01-05 08:29:59 EST
Thanks for the feedback.  I'll proceed down this path as time permits.
Comment 7 Russell Bryant 2012-01-15 11:21:39 EST
I have a proposed python-xattr ready to submit for review, pending the resolution of bug 781838.

  http://fedorapeople.org/~russellb/python-xattr/
Comment 8 Russell Bryant 2012-01-25 12:57:06 EST
Thanks to a tip from pbrady, I took a look at this issue from a different angle today.  All of what we have discussed here will no longer be necessary if this patch goes in:

https://review.openstack.org/#change,3414
Comment 9 Russell Bryant 2012-01-25 16:03:03 EST
That patch has gone into glance, so at least as of Essex, glance will work with the version of pyxattr already in Fedora.

Note You need to log in before you can comment on or make changes to this bug.