Bug 732845 - systemd dies during yum upgrades
Summary: systemd dies during yum upgrades
Keywords:
Status: CLOSED DUPLICATE of bug 732020
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-23 21:17 UTC by Michal Jaegermann
Modified: 2011-08-24 07:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-24 07:56:13 UTC


Attachments (Terms of Use)
some gdb information from a core file produced by systemd (3.20 KB, text/plain)
2011-08-23 21:19 UTC, Michal Jaegermann
no flags Details

Description Michal Jaegermann 2011-08-23 21:17:53 UTC
Description of problem:

After yum finished updating a number of packages on a system any attempt to 'reboot', 'halt', 'poweroff', or any other command of that sort end up with the following response:

Failed to open /dev/initctl: No such device or address
Failed to talk to init daemon.

/dev/initctl actually does exist, making this even more confusing, but checking processes reveals that systemd is gone.  Moreover in log files it is possible to find something of that kind:

yum[1759]: Updated: ImageMagick-c++-devel-6.7.1.9-1.fc17.x86_64
systemd[1]: Reloading.
systemd[1]: Caught <ABRT>, dumped core as pid 2166.
systemd[1]: Freezing execution.
yum[1759]: Updated: lvm2-2.02.88-1.fc17.x86_64

abrtd failed to catch that core.  With systemd-debuginfo and dbus-debuginfo installed gdb shows that dbus libraries call 
_dbus_warn_check_failed () with format=0x3c33a36010 "arguments to %s() were incorrect, assertion \"%s\" failed in file %s line %d.\nThis is normally a bug in some application using the D-Bus library.\n"
What values are supposed to be passed here to this format is for me unclear.
More of gdb output is attached. A core file is 5.6M in size (but xz reduces that  to 198K and that can be available if requested).

Bombing out from init does not look like an acceptable action does not matter what other userspace is doing.

Version-Release number of selected component (if applicable):
systemd-33-1.fc16

How reproducible:
This is the second incident of the same kind.  Both were with 
systemd-33-1.fc16.  I do not know if this is significant but the previous instance of "systemd[1]: Caught <ABRT>, dumped core ..." was followed immediately by "yum[1360]: Updated: lvm2-2.02.87-1.fc17.x86_64" so it was an lvm2 update as well.

Actual results:
Non-rebootable broken system.

Expected results:
Running init; bombing out from init does not look like an acceptable action does not matter what other userspace is doing.

Additional info:
This is the list of update which were running around time when this ABRT happened:

Aug 23 12:45:00 Updated: policycoreutils-2.1.4-1.fc17.x86_64
Aug 23 12:45:03 Updated: 6:kdelibs-common-4.7.0-4.fc17.x86_64
Aug 23 12:45:04 Updated: kde-settings-4.7-5.fc17.noarch
Aug 23 12:45:16 Updated: 6:kdelibs-4.7.0-4.fc17.x86_64
Aug 23 12:45:17 Updated: kdebase-runtime-flags-4.7.0-5.fc17.noarch
Aug 23 12:45:24 Updated: kdebase-runtime-4.7.0-5.fc17.x86_64
Aug 23 12:45:26 Updated: kdebase-runtime-libs-4.7.0-5.fc17.x86_64
Aug 23 12:45:26 Updated: ksysguardd-4.7.0-8.fc17.x86_64
Aug 23 12:45:28 Updated: kdebase-workspace-libs-4.7.0-8.fc17.x86_64
Aug 23 12:45:43 Updated: kdebase-workspace-4.7.0-8.fc17.x86_64
Aug 23 12:45:43 Updated: emacs-librep-0.92.1-1.fc17.x86_64
Aug 23 12:45:45 Updated: kbd-misc-1.15.3-1.fc17.noarch
Aug 23 12:45:46 Updated: kbd-1.15.3-1.fc17.x86_64
Aug 23 12:45:47 Updated: p11-kit-0.4-1.fc17.x86_64
Aug 23 12:45:49 Updated: p11-kit-devel-0.4-1.fc17.x86_64
Aug 23 12:45:51 Updated: pm-utils-1.4.1-12.fc17.x86_64
Aug 23 12:45:51 Updated: emacs-librep-el-0.92.1-1.fc17.x86_64
Aug 23 12:45:52 Updated: system-config-printer-1.3.6-1.fc17.x86_64
Aug 23 12:45:53 Updated: policycoreutils-python-2.1.4-1.fc17.x86_64
Aug 23 12:45:54 Updated: ImageMagick-c++-devel-6.7.1.9-1.fc17.x86_64
  <ABRT here >
Aug 23 12:45:56 Updated: lvm2-2.02.88-1.fc17.x86_64  
Aug 23 12:46:08 Updated: rhythmbox-2.90.1-13.git20110822.fc17.x86_64

and this is a similar list for the previous incident:

Aug 14 17:25:16 Updated: device-mapper-1.02.66-1.fc17.x86_64
Aug 14 17:25:18 Updated: device-mapper-libs-1.02.66-1.fc17.x86_64
Aug 14 17:25:20 Updated: 2:gimp-libs-2.6.11-21.fc17.x86_64
Aug 14 17:25:21 Updated: device-mapper-event-libs-1.02.66-1.fc17.x86_64
Aug 14 17:25:30 Updated: 2:gimp-2.6.11-21.fc17.x86_64
Aug 14 17:25:31 Updated: 12:dhcp-libs-4.2.2-2.fc17.x86_64
Aug 14 17:25:33 Updated: ufraw-common-0.18-3.fc17.x86_64
Aug 14 17:25:33 Updated: 12:dhcp-common-4.2.2-2.fc17.x86_64
Aug 14 17:25:37 Updated: device-mapper-event-1.02.66-1.fc17.x86_64
Aug 14 17:25:38 Updated: lvm2-libs-2.02.87-1.fc17.x86_64
Aug 14 17:25:38 Updated: 2:gimp-devel-tools-2.6.11-21.fc17.x86_64
Aug 14 17:25:42 Updated: 2:gimp-devel-2.6.11-21.fc17.x86_64
Aug 14 17:25:42 Updated: ksysguardd-4.7.0-5.fc17.x86_64
Aug 14 17:25:44 Updated: kdebase-workspace-libs-4.7.0-5.fc17.x86_64
Aug 14 17:25:55 Updated: kdebase-workspace-4.7.0-5.fc17.x86_64
  <ABRT here >
Aug 14 17:25:57 Updated: lvm2-2.02.87-1.fc17.x86_64
Aug 14 17:25:59 Updated: 12:dhclient-4.2.2-2.fc17.x86_64

Comment 1 Michal Jaegermann 2011-08-23 21:19:44 UTC
Created attachment 519523 [details]
some gdb information from a core file produced by systemd

Comment 2 Harald Hoyer 2011-08-24 07:56:13 UTC

*** This bug has been marked as a duplicate of bug 732020 ***


Note You need to log in before you can comment on or make changes to this bug.