Bug 732846 - Syntax errors in JavaScript cause jammit to fail silently and RPMs get 0 byte files
Summary: Syntax errors in JavaScript cause jammit to fail silently and RPMs get 0 byte...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Mike McCune
QA Contact: Katello QA List
URL:
Whiteboard:
: 732454 (view as bug list)
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-23 21:23 UTC by Mike McCune
Modified: 2013-03-27 20:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:53:20 UTC


Attachments (Terms of Use)

Description Mike McCune 2011-08-23 21:23:10 UTC
If there are syntax errors in any of our JavaScript files the jammit run during the RPM build will output 0 byte javascript files for the ones containing errors.

We discovered that we were using the reserved word: "package" for a variable in promotions.js:

promotion.js
/home/mmccune/devel/katello/src/public/javascripts/promotion.js(245): SyntaxError: missing name after . operator
                    if( !product.errata.length && !product.package.length && !product.repo.length ){
...........................................................^

You can see that .package is a reserved word:

https://developer.mozilla.org/en/JavaScript/Reference/reserved_words

Going to add a jslint run to our unit tests to catch these.

Comment 1 Bryan Kearney 2011-08-23 21:25:43 UTC
*** Bug 732454 has been marked as a duplicate of this bug. ***

Comment 2 Bryan Kearney 2011-09-02 22:12:41 UTC
I have seen this work.


Note You need to log in before you can comment on or make changes to this bug.