This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 732861 - FormatSetupError: invalid device specification
FormatSetupError: invalid device specification
Status: CLOSED DUPLICATE of bug 737916
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:431d8364e4285cba756a77421c5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-23 20:46 EDT by Erinn Looney-Triggs
Modified: 2011-09-15 16:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-15 16:42:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erinn Looney-Triggs 2011-08-23 20:46:26 EDT
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.x86_64
product:        Fedora
reason:         FormatSetupError: invalid device specification
time:           Tue Aug 23 18:45:45 2011
version:        16-Alpha

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.6 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 334, in setup
:    raise FormatSetupError("invalid device specification")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/luks.py", line 171, in setup
:    DeviceFormat.setup(self, *args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 844, in setupParents
:    _format.setup()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 701, in _preSetup
:    self.setupParents(orig=orig)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 712, in setup
:    if not self._preSetup(orig=orig):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2042, in turnOnSwap
:    device.setup()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1305, in turnOnSwap
:    upgrading=upgrading)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 151, in turnOnFilesystems
:    anaconda.storage.turnOnSwap()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
:    self.anaconda.dispatch.go_forward()
:FormatSetupError: invalid device specification
Comment 1 Erinn Looney-Triggs 2011-08-24 09:25:36 EDT
This one was lousy, happened during the formatting of partitions, formatted /boot/ then blew up, left me with a non functioning install of fedora. Looks to me like it doesn't like luks, but I am no expert.
Comment 2 Chris Lumens 2011-08-24 10:37:19 EDT
Can you please attach /tmp/anaconda-tb-* to this bug report as well?  I don't know why libreport didn't do that for us, but it's pretty annoying.
Comment 3 Erinn Looney-Triggs 2011-08-25 11:02:11 EDT
Well the third time through the install seems to be the charm as the issue did not occur again. Sorry I can't get you better debug info, I too thought it was all attached here.
Comment 4 David Lehman 2011-09-15 16:42:15 EDT
In the absence of critical information I am going on a hunch and closing this as a dupe of bug 737916.

*** This bug has been marked as a duplicate of bug 737916 ***

Note You need to log in before you can comment on or make changes to this bug.