Bug 737916 - FormatSetupError: invalid device specification
FormatSetupError: invalid device specification
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:f9198e9fe1344a27485d6d3da59...
:
: 732861 (view as bug list)
Depends On:
Blocks: F16Beta-accepted/F16BetaFreezeExcept F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-09-13 07:54 EDT by Petr Schindler
Modified: 2011-09-24 00:36 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-16.19-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-24 00:36:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (9.12 KB, text/x-log)
2011-09-14 06:20 EDT, Petr Schindler
no flags Details
program.log (147.88 KB, text/x-log)
2011-09-14 06:21 EDT, Petr Schindler
no flags Details
storage.log (488.39 KB, text/x-log)
2011-09-14 06:21 EDT, Petr Schindler
no flags Details
traceback for anaconda (956.62 KB, text/plain)
2011-09-15 07:10 EDT, Petr Schindler
no flags Details
disk layout (56.62 KB, image/png)
2011-09-15 07:35 EDT, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2011-09-13 07:54:25 EDT
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.1.0-0.rc3.git0.0.fc16.x86_64
product:        Fedora
reason:         FormatSetupError: invalid device specification
time:           Tue Sep 13 13:55:57 2011
version:        16

description:
:The following was filed automatically by anaconda:
:anaconda 16.17 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 334, in setup
:    raise FormatSetupError("invalid device specification")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/luks.py", line 171, in setup
:    DeviceFormat.setup(self, *args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 847, in setupParents
:    _format.setup()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 704, in _preSetup
:    self.setupParents(orig=orig)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 715, in setup
:    if not self._preSetup(orig=orig):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 482, in execute
:    self.device.setup(orig=True)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 316, in processActions
:    action.execute(intf=self.intf)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 383, in doIt
:    self.devicetree.processActions()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 122, in turnOnFilesystems
:    anaconda.storage.doIt()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 373, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 241, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1203, in nextClicked
:    self.anaconda.dispatch.go_forward()
:FormatSetupError: invalid device specification
Comment 1 Petr Schindler 2011-09-14 06:20:26 EDT
Created attachment 523115 [details]
anaconda.log
Comment 2 Petr Schindler 2011-09-14 06:21:02 EDT
Created attachment 523116 [details]
program.log
Comment 3 Petr Schindler 2011-09-14 06:21:32 EDT
Created attachment 523117 [details]
storage.log
Comment 4 Petr Schindler 2011-09-14 06:35:47 EDT
I have system with installed F15 on encrypted partition. I tried to install F16 on LVM encrypted partition to have dual boot. It crashes after I selected "write changes on disk" button.


Proposing as F16 Beta blocker, because it fails this criterion:

The installer must be able to complete an installation using the entire disk, existing free space, or existing Linux partitions methods, with or without encryption or LVM enabled
https://fedoraproject.org/wiki/Fedora_16_Alpha_Release_Criteria
Comment 5 Chris Lumens 2011-09-14 14:18:16 EDT
Could you attach the /tmp/anaconda-tb-* file when you hit this?  The logs are helpful, but the traceback file also tells us what device specification was invalid.
Comment 6 Tim Flink 2011-09-15 00:59:29 EDT
I tried to reproduce this in a VM but was not successful. I'm not sure that I understand your partition layout, though. Can you provide more details (PV encryption vs LV encryption, was everything on the same VG, separate /boot etc.)?

To grab the anaconda tb, you can use a test boot.iso that has a newer version of libreport in it:

http://tflink.fedorapeople.org/iso/20110914_preRC_boot3.x86_64.iso
http://tflink.fedorapeople.org/iso/20110914_preRC_boot3.x86_64.iso.sha256

However, unless I'm misunderstanding something I don't think that this would be a beta blocker since it is a very non-default partitioning scheme. It would qualify as a final blocker, though.

Unless more information comes up, I'm -1 beta blocker, +1 final blocker.
Comment 7 Petr Schindler 2011-09-15 07:10:00 EDT
Created attachment 523346 [details]
traceback for anaconda
Comment 8 Petr Schindler 2011-09-15 07:35:45 EDT
Created attachment 523357 [details]
disk layout

In layout.png you can find my disk layout. sda3 partition is encrypted and lv_devel is encrypted (not whole lvm volume). You can also see that I wanted to install root on lv_devel and /boot on sda4. Anaconda asked me for password to both encrypted partitions.
Comment 9 Petr Schindler 2011-09-15 07:52:13 EDT
bug 722952 I reproduced this bug when I unchecked encrypt in lv_devel (on which I wanted to have root) and then I tried to install as above.
Comment 10 David Lehman 2011-09-15 13:17:05 EDT
This is the same scenario as 722952 except that in this case the user first tried to reuse the root lv without reformatting and received an error stating the he/she must reformat the root device. The fix for bug 723303 would have caught the invalid path except that it is only checked if the device is not being reformatted. The fix for this will be to move that check up so that it gets performed whenever an existing lv is being reused.
Comment 11 Adam Williamson 2011-09-15 15:46:32 EDT
So, this (and 722952) is a clear final blocker under the 'any workable layout' final criterion. For Beta the situation is less clear: it's a partial infringement of "The installer must be able to complete an installation using the entire disk, existing free space, or existing Linux partitions methods, with or without encryption or LVM enabled" (Alpha criterion). Now we have an RC and a deadline, we're at the point where we need to judge the benefit/danger trade-off of taking another anaconda build. Let's talk it over at the blocker review meeting tomorrow. On instinct I'm lightly in favour of taking this as a blocker and including a new anaconda build with the patches for this in RC2.
Comment 12 Adam Williamson 2011-09-15 15:47:46 EDT
dlehman remarks "[unless we take the fixes], changing anything in the lvm dialogs is fraught with danger"..."if these patches weren't all three fixes to regressions caused by similarly simple-seeming fixes in those dialogs I would be telling you that they are pretty safe".
Comment 13 Adam Williamson 2011-09-15 15:50:51 EDT
the patches for this are to be found in this anaconda-devel thread:

https://www.redhat.com/archives/anaconda-devel-list/2011-September/msg00122.html

they look nice and small, but as dlehman notes, we already know that small, 'obvious' changes can break a lot of stuff when it comes to handling LVs.

Note that if we took an anaconda build that fixed these bugs but it caused major, major regressions, we would have the option of changing our minds and going back to 16.18, I guess: we wouldn't be stuck trying to firefight the regressions.
Comment 14 David Lehman 2011-09-15 16:41:18 EDT
An updates image is available for those who would like to test/verify a fix. Add the following to the boot command line if interested:

  updates=http://dlehman.fedorapeople.org/updates-lvm.img
Comment 15 David Lehman 2011-09-15 16:42:15 EDT
*** Bug 732861 has been marked as a duplicate of this bug. ***
Comment 16 Adam Williamson 2011-09-15 18:16:06 EDT
we are also interested in general testing of RC1 with the updates image, not just specific testing to see if it resolves this bug, but also to see if it causes any other problems.
Comment 17 Tim Flink 2011-09-16 02:20:55 EDT
I did some simple testing with dlehman's update.img and haven't seen any issues yet.

I did a couple of vanilla full disk installs with lvm and a more complicated setup. I did hit #733449 but nothing LVM related.
Comment 18 Tim Flink 2011-09-16 22:19:39 EDT
Discussed in the 2011-09-16 blocker review meeting. Rejected as Fedora 16 blocker as it doesn't hit any of the release criteria. However, it would be nice to fix and a patch is almost ready - accepted as NTH for Fedora 16 Beta.

This was accepted as a blocker for Fedora 16 final because it hist the following final release criteria [1]:

The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above 

[1] https://fedoraproject.org/wiki/Fedora_16_Final_Release_Criteria
Comment 19 Petr Schindler 2011-09-17 08:36:16 EDT
Works for me with dlehman's update.img. Installation completed successfully.
Comment 20 Adam Williamson 2011-09-22 21:35:56 EDT
dlehman: again, is this going to be committed for 16.19? thanks!
Comment 21 David Lehman 2011-09-23 10:08:10 EDT
Yes. It will be in anaconda-16.19.
Comment 22 Fedora Update System 2011-09-23 17:49:10 EDT
anaconda-16.19-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.19-1.fc16
Comment 23 Fedora Update System 2011-09-24 00:35:47 EDT
anaconda-16.19-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.