Bug 733047 - [abrt] kernel: [499045.744181] WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:267 radeon_fence_wait+0x296/0x33d [radeon](): TAINTED ---------W
Summary: [abrt] kernel: [499045.744181] WARNING: at drivers/gpu/drm/radeon/radeon_fenc...
Keywords:
Status: CLOSED DUPLICATE of bug 726857
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:760477b6b2cf21259dd67b89424...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-24 15:03 UTC by Nicolas Berrehouc
Modified: 2011-08-30 20:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-30 20:57:40 UTC


Attachments (Terms of Use)

Description Nicolas Berrehouc 2011-08-24 15:03:31 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        ro root=/dev/mapper/Fedora-System rd_LVM_LV=Fedora/System rd_LVM_LV=Fedora/Swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=fr_FR.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=fr-latin9
component:      kernel
kernel:         2.6.40.3-0.fc15.x86_64
kernel_tainted: 512
kernel_tainted_long: Taint on warning.
os_release:     Fedora release 15 (Lovelock)
package:        kernel
reason:         [499045.744181] WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:267 radeon_fence_wait+0x296/0x33d [radeon]()
time:           Wed Aug 24 15:57:56 2011

backtrace:
:[499045.744181] WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:267 radeon_fence_wait+0x296/0x33d [radeon]()
:[499045.744184] Hardware name:  
:[499045.744186] GPU lockup (waiting for 0x04E8B056 last fence id 0x04E8B055)
:[499045.744189] Modules linked in: vfat fat usb_storage usblp tcp_lp fuse sunrpc cpufreq_ondemand powernow_k8 freq_table mperf nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack it87 hwmon_vid snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec rt3070sta snd_hwdep snd_seq snd_seq_device snd_pcm nv_tco snd_timer snd ppdev parport_pc i2c_nforce2 forcedeth edac_core soundcore snd_page_alloc edac_mce_amd k8temp parport ipv6 firewire_ohci firewire_core pata_acpi ata_generic crc_itu_t sata_nv pata_amd radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:[499045.744228] Pid: 1224, comm: Xorg Not tainted 2.6.40.3-0.fc15.x86_64 #1
:[499045.744231] Call Trace:
:[499045.744240]  [<ffffffff81054c8e>] warn_slowpath_common+0x83/0x9b
:[499045.744245]  [<ffffffff81054d49>] warn_slowpath_fmt+0x46/0x48
:[499045.744271]  [<ffffffffa00d2579>] ? evergreen_gpu_is_lockup+0xba/0xc2 [radeon]
:[499045.744291]  [<ffffffffa0098dcd>] radeon_fence_wait+0x296/0x33d [radeon]
:[499045.744296]  [<ffffffff81070442>] ? remove_wait_queue+0x3a/0x3a
:[499045.744319]  [<ffffffffa00aa8d4>] radeon_ib_get+0xf1/0x178 [radeon]
:[499045.744342]  [<ffffffffa00abd19>] radeon_cs_ioctl+0x99/0x19b [radeon]
:[499045.744361]  [<ffffffffa00157f7>] drm_ioctl+0x29e/0x37b [drm]
:[499045.744385]  [<ffffffffa00abc80>] ? radeon_cs_finish_pages+0x8e/0x8e [radeon]
:[499045.744391]  [<ffffffff811f6290>] ? inode_has_perm+0x32/0x34
:[499045.744394]  [<ffffffff811f6339>] ? file_has_perm+0xa7/0xc9
:[499045.744399]  [<ffffffff81134e06>] do_vfs_ioctl+0x460/0x4a1
:[499045.744403]  [<ffffffff81134e9d>] sys_ioctl+0x56/0x79
:[499045.744408]  [<ffffffff8148e182>] system_call_fastpath+0x16/0x1b

comment:
:At 15:57 Gnome-Shell freezed. Same issue that bug 716738 - [JUNIPER] gnome-shell crash ( https://bugzilla.redhat.com/show_bug.cgi?id=716738 )
:
:$ lspci 
:02:00.1 Audio device: ATI Technologies Inc Juniper HDMI Audio [Radeon HD 5700 Series]

Comment 1 Nicolas Berrehouc 2011-08-28 06:21:22 UTC
Similar freeze with an another computer.

$ lspci
VGA compatible controller: ATI Technologies Inc Redwood PRO [Radeon HD 5500 Series]

backtrace from abrt :
WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:267 radeon_fence_wait+0x296/0x33d [radeon]()
Hardware name: GA-990FXA-UD3
GPU lockup (waiting for 0x0054AF76 last fence id 0x0054AF72)
Modules linked in: udf ses enclosure usb_storage uas tcp_lp fuse sunrpc cpufreq_ondemand powernow_k8 freq_table mperf ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack it87 hwmon_vid joydev snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel microcode snd_hda_codec snd_usb_audio snd_seq snd_pcm sp5100_tco edac_core edac_mce_amd k10temp serio_raw uvcvideo snd_timer snd_hwdep videodev snd_usbmidi_lib snd_rawmidi media snd_seq_device v4l2_compat_ioctl32 snd soundcore xhci_hcd r8169 mii i2c_piix4 snd_page_alloc ipv6 firewire_ohci firewire_core crc_itu_t mxm_wmi pata_acpi ata_generic wmi radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
Pid: 1261, comm: Xorg Not tainted 2.6.40.3-0.fc15.x86_64 #1
Call Trace:
 [<ffffffff81054c8e>] warn_slowpath_common+0x83/0x9b
 [<ffffffff81054d49>] warn_slowpath_fmt+0x46/0x48
 [<ffffffffa00d2579>] ? evergreen_gpu_is_lockup+0xba/0xc2 [radeon]
 [<ffffffffa0098dcd>] radeon_fence_wait+0x296/0x33d [radeon]
 [<ffffffff81070442>] ? remove_wait_queue+0x3a/0x3a
 [<ffffffffa00993c1>] radeon_sync_obj_wait+0x11/0x13 [radeon]
 [<ffffffffa0060642>] ttm_bo_wait+0xbf/0x17a [ttm]
 [<ffffffffa006106a>] ? ttm_bo_list_ref_sub+0x29/0x2b [ttm]
 [<ffffffffa00a9dbb>] radeon_bo_wait+0x7b/0x9f [radeon]
 [<ffffffffa00aa31d>] radeon_gem_wait_idle_ioctl+0x3d/0x70 [radeon]
 [<ffffffffa00157f7>] drm_ioctl+0x29e/0x37b [drm]
 [<ffffffffa00aa2e0>] ? radeon_gem_busy_ioctl+0x86/0x86 [radeon]
 [<ffffffff811f6290>] ? inode_has_perm+0x32/0x34
 [<ffffffff811f6339>] ? file_has_perm+0xa7/0xc9
 [<ffffffff81134e06>] do_vfs_ioctl+0x460/0x4a1
 [<ffffffff810a0f91>] ? audit_syscall_exit+0x12d/0x148
 [<ffffffff81134e9d>] sys_ioctl+0x56/0x79
 [<ffffffff8148e435>] ? int_check_syscall_exit_work+0x34/0x3d
 [<ffffffff8148e182>] system_call_fastpath+0x16/0x1b

Comment 2 Dave Jones 2011-08-30 20:57:40 UTC

*** This bug has been marked as a duplicate of bug 726857 ***


Note You need to log in before you can comment on or make changes to this bug.