Bug 733079 - Cyrus-imapd: login not possible, method nod permitted before handle's open method
Summary: Cyrus-imapd: login not possible, method nod permitted before handle's open me...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cyrus-imapd
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-24 16:09 UTC by Grosswiler Roger
Modified: 2011-11-09 14:20 UTC (History)
3 users (show)

Fixed In Version: cyrus-imapd-2.4.10-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-09 14:20:13 UTC


Attachments (Terms of Use)

Description Grosswiler Roger 2011-08-24 16:09:31 UTC
Description of problem:
Login not possible using cyrus-sasl


Version-Release number of selected component (if applicable):
cyrus-imapd-2.4.10-1.fc15

How reproducible:
Always


Steps to Reproduce:
1. Upgrade to Cyrus 2.4.10-1 and latest sasl
2. login using cram-md5 (did not check other auth methods) - gives error
3. yum downgrade cyrus-sasl, restart saslauthd
4. login using cram-md5 still giving error
5. yum downgrade cyrus-imapd, restart cyrus-imapd
6. login works
7. yum update cyrus-sasl
8. login works
  
Actual results:
using version 2.4.10-1.fc15 of cyrus-imapd, you get the following error:
-> in /var/log/messages: 
unable to open berkeley db /etc/sasldb2: invalid argument

-> when telnetting manually
DB->put: method nod permitted before handle's open method
DB->compact: method not permitted before handle's open method
DB->put: method nod permitted before handle's open method
DB->compact: method not permitted before handle's open method
...NO login failed: authentication failure


Expected results:
login in cyrus-imapd, having mails


Additional info:
i found several infos, this could be a kind of deadlock, nevertheless i am not a pro. 

this has to be handled extremly urgently, as this could make lots of big productive environements unusable.

Comment 1 Grosswiler Roger 2011-08-24 16:34:22 UTC
Info 2: i had now to downgrade cyrus-imapd as cyrus-sasl, as i did no longer work with the combination.

btw. a reboot did resolve the problem partially

Comment 2 Michal Hlavinka 2011-08-24 16:43:30 UTC
Thanks for reporting this. Seems that update of cyrus-sasl to berkley db v. 5 caused more troubles, but I don't know why it was updated.
Anyway, you can try to downgrade cyrus-sasl for workaround:

yum downgrade 'cyrus-sasl*'

it should help. 

I've already rebuilt cyrus-imapd with updated libdb v. 5, it's in updates-testing now, but it's not installable, because we need libdb-utils which conflicts with db4-utils (rpm needs it). So fixing this will take some time...

Comment 3 Matthias Haase 2011-09-06 09:51:09 UTC
While libdb-utils doesn't conflict with db4-utils anymore at present there is now a new issue: smtp-auth using postfix doesn't work anymore because postfix is unable to handle the new cyrus-sasl too...

Comment 4 Michal Hlavinka 2011-09-09 08:25:17 UTC
postfix issue is known (bug #734084)


Note You need to log in before you can comment on or make changes to this bug.