Bug 733170 - LVMError: lvdeactivate failed for root: LV ubuntu/root in use: not deactivating
Summary: LVMError: lvdeactivate failed for root: LV ubuntu/root in use: not deactiva...
Keywords:
Status: CLOSED DUPLICATE of bug 693095
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b2b91e9e4cc7d468017443f48aa...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 01:53 UTC by Vadym Chepkov
Modified: 2011-08-27 00:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-27 00:04:45 UTC


Attachments (Terms of Use)
anaconda-tb log (52.66 KB, application/x-gzip)
2011-08-26 00:31 UTC, Vadym Chepkov
no flags Details

Description Vadym Chepkov 2011-08-25 01:53:02 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.i686
product:        Fedora
reason:         LVMError: lvdeactivate failed for root:   LV ubuntu/root in use: not deactivating
time:           Thu Aug 25 01:51:56 2011
version:        16-Alpha

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.6 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicelibs/lvm.py", line 400, in lvdeactivate
:    raise LVMError("lvdeactivate failed for %s: %s" % (lv_name, msg))
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 2561, in _teardown
:    lvm.lvdeactivate(self.vg.name, self._name)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 758, in teardown
:    self._teardown(recursive=recursive)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 283, in __init__
:    device.teardown()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 917, in destroyDevice
:    action = ActionDestroyDevice(device)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 450, in clearPartitions
:    storage.destroyDevice(leaf)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 259, in doAutoPartition
:    clearPartitions(anaconda.storage, bootloader=anaconda.bootloader)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
:    self.dispatch()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
:    self.anaconda.dispatch.go_forward()
:LVMError: lvdeactivate failed for root:   LV ubuntu/root in use: not deactivating
:

Comment 1 Chris Lumens 2011-08-25 13:23:03 UTC
Please attach /tmp/anaconda-tb-* to this bug report.  It should have been attached automatically by the bug filing mechanism, but that appears to have been broken in F16 alpha.

Comment 2 Vadym Chepkov 2011-08-26 00:27:11 UTC
Just so you have more details - this PC has Ubuntu installed with LVM configured and I have selected to use all disk, so anaconda fails to remove existing LVM configuration

Comment 3 Vadym Chepkov 2011-08-26 00:31:06 UTC
Created attachment 519996 [details]
anaconda-tb log

Comment 4 Brian Lane 2011-08-27 00:04:45 UTC

*** This bug has been marked as a duplicate of bug 693095 ***


Note You need to log in before you can comment on or make changes to this bug.