Bug 693095 - LVMError: lvdeactivate failed for lv_root: LV vg_ibm623041ukph/lv_root in use: not deactivating
LVMError: lvdeactivate failed for lv_root: LV vg_ibm623041ukph/lv_root in u...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:273de2a48a9cec853...
:
: 731264 733048 733170 733541 742638 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-02 11:59 EDT by Charles McGowen
Modified: 2011-10-03 10:33 EDT (History)
18 users (show)

See Also:
Fixed In Version: anaconda-16.17-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 15:38:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (325.47 KB, text/plain)
2011-04-02 11:59 EDT, Charles McGowen
no flags Details
Attached traceback automatically from anaconda. (325.39 KB, text/plain)
2011-04-03 10:58 EDT, Charles McGowen
no flags Details
logs (290.00 KB, application/x-tar)
2011-08-31 04:19 EDT, Kamil Páral
no flags Details
as requested by comment 16 (1.07 MB, text/plain)
2011-09-15 15:53 EDT, Eric Blake
no flags Details

  None (edit)
Description Charles McGowen 2011-04-02 11:59:41 EDT
The following was filed automatically by anaconda:
anaconda 14.22 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicelibs/lvm.py", line 413, in lvdeactivate
    raise LVMError("lvdeactivate failed for %s: %s" % (lv_name, msg))
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 2395, in teardown
    lvm.lvdeactivate(self.vg.name, self._name)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1315, in findExistingRootDevices
    device.teardown(recursive=True)
  File "/usr/lib/python2.7/site-packages/pyanaconda/upgrade.py", line 110, in findExistingRoots
    return findExistingRootDevices(anaconda, upgradeany=upgradeany)
  File "/usr/lib/python2.7/site-packages/pyanaconda/upgrade.py", line 81, in findRootParts
    flags.cmdline.has_key("upgradeany"))
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in currentStep
    self.gotoNext()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1223, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1411, in setup_window
    self.setScreen()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1425, in run
    self.setup_window(False)
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1154, in run
    self.icw.run()
  File "/usr/bin/anaconda", line 901, in <module>
    anaconda.intf.run(anaconda)
LVMError: lvdeactivate failed for lv_root:   LV vg_ibm623041ukph/lv_root in use: not deactivating
Comment 1 Charles McGowen 2011-04-02 11:59:47 EDT
Created attachment 489598 [details]
Attached traceback automatically from anaconda.
Comment 2 Charles McGowen 2011-04-03 10:58:46 EDT
Created attachment 489658 [details]
Attached traceback automatically from anaconda.
Comment 3 Chris Lumens 2011-04-04 15:38:57 EDT
Is this reproducible with F15 alpha or beta?
Comment 4 Brian Lane 2011-08-26 20:04:15 EDT
*** Bug 733541 has been marked as a duplicate of this bug. ***
Comment 5 Brian Lane 2011-08-26 20:04:45 EDT
*** Bug 733170 has been marked as a duplicate of this bug. ***
Comment 6 Kamil Páral 2011-08-31 04:19:12 EDT
Created attachment 520759 [details]
logs

I reproduced this issue while testing fix for bug #728883. Attaching logs.
Comment 7 David Lehman 2011-09-01 14:51:32 EDT
I expect this to be fixed in F16-Beta.TC1. The fix was a change to lorax that landed in lorax-16.4.2-1.
Comment 8 Kamil Páral 2011-09-02 02:47:42 EDT
I hit this issue with F16 Beta TC1, when using updates.img for working around #728883. Probably not fixed yet.
Comment 9 David Lehman 2011-09-02 12:18:20 EDT
I see what the problem here is after another look. Try with this on your kernel command line:

 updates=http://dlehman.fedorapeople.org/updates-693095.img


This also contains Ales' fix for bug 728883.
Comment 10 Jon Disnard 2011-09-04 12:13:26 EDT
FC16 alpha here.

Performing a DVD install into a virtualbox VM.
The VM was previously used for FC15 testing, so this is a reinstall over existing.

I used David's updates-693095.img file. 
Unfortunately that causes another issue.


Running anaconda 16.14.6, the fedora system installer - please wait.
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 614, in <module>
    from pyanaconda import kickstart
  File "/tmp/updates/pyanaconda/kickstart.py", line 235, in <module>
    class AutoPart(commands.autopart.F16)AutoPart):
AttributeError: 'module' object has no attribute 'F16_AutoPart'
Comment 11 Kamil Páral 2011-09-05 05:42:48 EDT
(In reply to comment #9)
> I see what the problem here is after another look. Try with this on your kernel
> command line:
> 
>  updates=http://dlehman.fedorapeople.org/updates-693095.img
> 
> 
> This also contains Ales' fix for bug 728883.

This updates.img fixes the problem for me.
Comment 12 Fedora Update System 2011-09-08 13:28:45 EDT
anaconda-16.17-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.17-1.fc16
Comment 13 Fedora Update System 2011-09-08 16:49:48 EDT
Package anaconda-16.17-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-16.17-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-16.17-1.fc16
then log in and leave karma (feedback).
Comment 14 Eric Blake 2011-09-14 20:31:37 EDT
I just encountered this crash with F16 beta TC2 live image, which has anaconda-16.17-1.fc16.x86_64.  What other details should I provide?
Comment 15 Eric Blake 2011-09-14 23:49:40 EDT
anaconda-16.18-1.fc16.x86_64 also crashed for me.  The tail of /tmp/anaconda.log includes:

21:28:02,537 DEBUG anaconda: dispatch: enablefilesystems is a direct step
21:40:26,444 CRIT anaconda: anaconda 16.18 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicelibs/lvm.py"
, line 400, in lvdeactivate
    raise LVMError("lvdeactivate failed for %s: %s" % (lv_name, msg))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 
2589, in _teardown
    lvm.lvdeactivate(self.vg.name, self._name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 
761, in teardown
    self._teardown(recursive=recursive)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", 
line 485, in execute
    self.device.teardown()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 316, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 384, in doIt
    self.devicetree.processActions()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 122, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 373, in dispatch
    self.dir = self.steps[self.step].target(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 241, in go_forward
    self.dispatch()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1203, in nextClicked
    self.anaconda.dispatch.go_forward()
LVMError: lvdeactivate failed for lv_root_rawhide:   Volume group "vg_tower" not found
  Skipping volume group vg_tower

I was trying to set up a custom install, where vg_tower is a pre-existing volume group with five partitions (swap, shared /home, and three different / of a triple-boot machine) as well as some free space, and where I was selecting /home without reformatting as well as one of the partitions to be formatted as /.
Comment 16 David Lehman 2011-09-15 11:45:34 EDT
(In reply to comment #14)
> I just encountered this crash with F16 beta TC2 live image, which has
> anaconda-16.17-1.fc16.x86_64.  What other details should I provide?

Please attach the file matching /tmp/anaconda-tb-* to this bug report as a plain text attachment. Thanks.
Comment 17 Eric Blake 2011-09-15 11:51:14 EDT
Will do, once I reflash my liveusb to go back to a point where I can reproduce it (I just upgraded to beta rc1, and the problem seems to be gone).
Comment 18 Eric Blake 2011-09-15 15:53:04 EDT
Created attachment 523437 [details]
as requested by comment 16
Comment 19 David Lehman 2011-09-15 17:12:15 EDT
(In reply to comment #17)
> Will do, once I reflash my liveusb to go back to a point where I can reproduce
> it (I just upgraded to beta rc1, and the problem seems to be gone).

Your error is really different from the one described in this bug. Did you say that this error is no longer occurring with later trees on a system that exhibits the failure? If so, that indicates the problem has been resolved one way or another. If not, please file a separate bug.
Comment 20 Eric Blake 2011-09-15 17:23:35 EDT
(In reply to comment #19)
> (In reply to comment #17)
> > Will do, once I reflash my liveusb to go back to a point where I can reproduce
> > it (I just upgraded to beta rc1, and the problem seems to be gone).
> 
> Your error is really different from the one described in this bug. Did you say
> that this error is no longer occurring with later trees on a system that
> exhibits the failure? If so, that indicates the problem has been resolved one
> way or another. If not, please file a separate bug.

Both stock beta TC2, and TC2 plus hand-upgrading to anaconda-16.18-1, hit the bug; but beta RC1 (which also has anaconda-16.18-1) succeeded.  Since the problem went away with RC1, I don't think we need any further bugs filed, but it is still rather annoying that I don't have a root cause (the same anaconda version in both my hand-upgraded TC2 and RC1, so it was the interaction with some other package that also got upgraded for RC1, and without knowing which package made the difference, we risk regressing in the future).
Comment 21 David Lehman 2011-09-15 21:20:17 EDT
There's a bunch of mess in your syslog from udev and things it's trying to run, so my money's on either a udev or kernel update.
Comment 22 David Lehman 2011-09-26 17:01:51 EDT
*** Bug 731264 has been marked as a duplicate of this bug. ***
Comment 23 David Lehman 2011-09-28 11:54:39 EDT
*** Bug 733048 has been marked as a duplicate of this bug. ***
Comment 24 Fedora Update System 2011-09-30 15:38:23 EDT
anaconda-16.17-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 David Lehman 2011-10-03 10:33:33 EDT
*** Bug 742638 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.