Bug 733286 - TypeError: expected string or buffer
Summary: TypeError: expected string or buffer
Keywords:
Status: CLOSED DUPLICATE of bug 728883
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1e9967ffaadfb1c6bd98121e2fb...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 11:21 UTC by Srinivasa
Modified: 2011-08-25 13:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-25 13:17:32 UTC


Attachments (Terms of Use)

Description Srinivasa 2011-08-25 11:21:02 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.i686
product:        Fedora
reason:         TypeError: expected string or buffer
time:           Thu Aug 25 11:15:57 2011
version:        16-Alpha

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.6 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/re.py", line 137, in match
:    return _compile(pattern, flags).match(string)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/installclass.py", line 207, in archesEq
:    if re.match("i.86", a) and re.match("i.86", b):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/installclass.py", line 212, in productUpgradable
:    return self.productMatches(oldprod) and self.versionMatches(oldver) and archesEq(arch, productArch)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1524, in findExistingRootDevices
:    anaconda.instClass.productUpgradable(arch, product, version):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/upgrade.py", line 81, in findRootParts
:    upgradeany=flags.cmdline.has_key("upgradeany"))
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
:    self.dispatch()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
:    self.anaconda.dispatch.go_forward()
:  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1321, in keyRelease
:    self.nextClicked()
:TypeError: expected string or buffer

Comment 1 Ales Kozumplik 2011-08-25 13:17:32 UTC

*** This bug has been marked as a duplicate of bug 728883 ***


Note You need to log in before you can comment on or make changes to this bug.