Bug 73332 - gnome-terminal leaks memory rapidly
gnome-terminal leaks memory rapidly
Status: CLOSED DUPLICATE of bug 76219
Product: Red Hat Linux
Classification: Retired
Component: vte (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-03 00:26 EDT by Damien Miller
Modified: 2007-04-18 12:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Damien Miller 2002-09-03 00:26:56 EDT
Description of Problem:

gnome-terminal leaks memory in proportion to the amount of output it displays

Version-Release number of selected component (if applicable):

gnome-terminal-2.0.1-3
vte-0.8.8-1

How Reproducible:

Always

Steps to Reproduce:
1. Start gnome-terminal
2. run "top"
3. press "M" to sort by memory
4. Hold down space-bar to cause lots of output

Actual Results:

a single gnome-terminal rapidly grows past 80M RSS

Expected Results:

An order of magnitude less

Additional Information:
	
This is not bug #73226 - my blinking cursor is already disabled
Comment 1 Damien Miller 2002-09-03 04:12:55 EDT
This is not improved by vte-0.8.13-1 from rawhide
Comment 2 Richard Torkar 2002-09-03 11:30:47 EDT

Hmm I'm trying to do the same here and it doesn't work as you say.
My gnome-terminal is constantly sitting on 10MB RSS

rpm -q gnome-terminal vte gives this:
gnome-terminal-2.0.1-3
vte-0.8.8-1
Comment 3 Damien Miller 2002-09-04 21:27:55 EDT
I tried resetting gnome-terminal to defaults, but I still get it leaking. This
is after about 30 seconds in "top" with the spacebar held down to force it to
update quickly:

  PID USER PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM  TIME COMMAND
1865 djm   15   0  118M 118M  6640 R     3.5 49.1   0:12 gnome-terminal
Comment 4 Havoc Pennington 2002-09-04 22:01:03 EDT
there's at least a 0.8.15 that should be appearing soon if it hasn't.
Comment 5 Damien Miller 2002-09-15 20:12:55 EDT
vte-0.8.14-1 doesn't help either
Comment 6 Need Real Name 2002-09-19 18:06:44 EDT
I have the same problem (gnome-terminal using up all my memory) when I use
anti-aliased fonts.  gnome-terminal behaves correctly when using the
"monochrome" font setting.  Perhaps this gives some indication where the problem
is ... I surely hope so.
Comment 7 Jordan Russell 2002-10-02 19:38:26 EDT
I see the same bevahior as rh@fruru.com under Red Hat 8.0.

But this doesn't seem to be limited to gnome-terminal. I see similar leaks in 
other apps, like gedit, when anti-aliasing is enabled. Not good!
Comment 8 Nalin Dahyabhai 2002-10-17 20:30:14 EDT
If you run "xdpyinfo", is RENDER one of the listed extensions?
Comment 9 Jordan Russell 2002-10-17 20:57:59 EDT
In my case, no.

I'm running under VMware 3.2 in case it matters...
Comment 10 Need Real Name 2002-10-19 08:52:51 EDT
No RENDER extension here either.

Video card is a I830 (in a laptop)

Cheers and good hunting
Tycho
Comment 11 Nalin Dahyabhai 2003-05-30 19:08:39 EDT

*** This bug has been marked as a duplicate of 76219 ***
Comment 12 Red Hat Bugzilla 2006-02-21 13:49:34 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.