Bug 733341 - base-db updates for RH High Availability
Summary: base-db updates for RH High Availability
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor-wallaby-base-db
Version: Development
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: 2.1
: ---
Assignee: Robert Rati
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks: 580270 743350
TreeView+ depends on / blocked
 
Reported: 2011-08-25 14:01 UTC by Robert Rati
Modified: 2012-01-23 17:28 UTC (History)
4 users (show)

Fixed In Version: condor-wallaby-base-db-1.15-1
Doc Type: Bug Fix
Doc Text:
In order to use Red Hat High Availability to manage the HAScheduler feature setup, manual modifications to the HAScheduler feature in the base-db were required. With this update, new feature named "BaseHAScheduler" has been added to be base-db and no manual modifications to features in the base-db are now necessary in the described scenario.
Clone Of:
Environment:
Last Closed: 2012-01-23 17:28:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0045 normal SHIPPED_LIVE Red Hat Enterprise MRG Grid 2.1 bug fix and enhancement update 2012-01-23 22:22:58 UTC

Description Robert Rati 2011-08-25 14:01:04 UTC
Description of problem:
Need to update the base-db to allow Red Hat's High Availability to manage the job queue.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Robert Rati 2011-08-29 19:20:53 UTC
pushed upstream on branch:
BZ580270-other-schedd-controllers

Comment 2 Robert Rati 2011-09-06 20:03:30 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
C: Use Red Hat High Availability to manage a HA Scheduler setup.
C: Manual modifications to the HAScheduler feature in the base-db were needed.
F: A new feature named "BaseHAScheduler" was added to be base-db
R: No manual modifications to features in the base-db are needed.

Comment 3 Robert Rati 2011-09-06 20:11:57 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1,4 @@
 C: Use Red Hat High Availability to manage a HA Scheduler setup.
 C: Manual modifications to the HAScheduler feature in the base-db were needed.
-F: A new feature named "BaseHAScheduler" was added to be base-db
+C: A new feature named "BaseHAScheduler" was added to be base-db
 R: No manual modifications to features in the base-db are needed.

Comment 5 Lubos Trilety 2011-10-06 13:35:51 UTC
BaseHAScheduler was added to base-db.

# ccs -l -f BaseHAScheduler
Feature "BaseHAScheduler":
Feature ID: 33
Name: BaseHAScheduler
Included Parameters:
  SCHEDD_NAME = 
Included Features:
  0: JobQueueLocation
  1: BaseScheduler
Conflicts:
  Scheduler
Dependencies:

Tested on:
condor-wallaby-base-db-1.16-1

>>> VERIFIED

Comment 6 Tomas Capek 2011-11-16 15:59:31 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1 @@
-C: Use Red Hat High Availability to manage a HA Scheduler setup.
+In order to use Red Hat High Availability to manage the HAScheduler feature setup, manual modifications to the HAScheduler feature in the base-db were required. With this update, new feature named "BaseHAScheduler" has been added to be base-db and no manual modifications to features in the base-db are now necessary in the described scenario.-C: Manual modifications to the HAScheduler feature in the base-db were needed.
-C: A new feature named "BaseHAScheduler" was added to be base-db
-R: No manual modifications to features in the base-db are needed.

Comment 7 errata-xmlrpc 2012-01-23 17:28:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0045.html


Note You need to log in before you can comment on or make changes to this bug.