Bug 73335 - diskcheck ignores configurtion "defaultCutoff=xx"
diskcheck ignores configurtion "defaultCutoff=xx"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: diskcheck (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
: 90528 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-03 01:33 EDT by Dirk Czirpka
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-09 08:42:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dirk Czirpka 2002-09-03 01:33:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
After updade from diskcheck-1.1-1.noarch.rpm (this rpm works) to diskcheck-1.2-
1.noarch.rpm or diskcheck-1.3-2.noarch.rpm is not working any more.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade from RH 7.2 to RH 7.3 (update to diskcheck-1.3-2)
2. Set "defaultCutoff=10" (some partition has more than 10% used)
3. Exec "/etc/cron.hourly/diskcheck"
=> no mail send

another try:
1. Install an RH 7.3 out of the box
2. Set "defaultCutoff=10" (some partition has more than 10% used)
3. Exec "/etc/cron.hourly/diskcheck"
=> no mail send	

Actual Results:  no mail send

Expected Results:  mail about low disk space

Additional info:
Comment 1 Harald Hoyer 2002-11-05 06:35:14 EST
Had to make the following changes...
if cutoff.has_key(volume):
        if (nPct < long(cutoff[volume])): continue
    elif cutoff.has_key(mountpt):
        if (nPct < long(cutoff[mountpt])): continue
    elif (nPct < long(conf['defaultCutoff'])): continue

Note the use of the long() typecast.
Comment 2 Harald Hoyer 2002-11-05 07:29:08 EST
should be fixed in diskcheck >= 1.4
Comment 3 Harald Hoyer 2003-05-09 08:41:51 EDT
*** Bug 90528 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.