Bug 90528 - diskcheck fails to produce report
Summary: diskcheck fails to produce report
Status: CLOSED DUPLICATE of bug 73335
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: diskcheck   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-09 12:32 UTC by Ivan Teliatnikov
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ivan Teliatnikov 2003-05-09 12:32:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0 (CK-APC)

Description of problem:
Dick check failes to report problme due to the problem in the diskcheck python
script.

For example adding the following line into a script ( line 300 )
print nPct  conf['defaultCutoff']
output:
90L 95

90L - is a percent of file spaced filled.
95 - percent of the default CutOff.
 
elif (nPct < conf['defaultCutoff']): continue # fails to compare, perhaps python
thinks that mPct is an integer, whilst conf['defaultCutoff'] is string ? Sorry
cannot say more, debugging this is script is my first programming experience in
python.

# % of filled file space on a mounted file system



*** diskcheck   2002-05-30 22:21:59.000000000 +1000
--- diskcheck.fixed     2003-05-09 22:04:15.000000000 +1000
***************
*** 295,304 ****
          continue

      if cutoff.has_key(volume):
!         if (nPct < cutoff[volume]): continue
      elif cutoff.has_key(mountpt):
!         if (nPct < cutoff[mountpt]): continue
!     elif (nPct < conf['defaultCutoff']): continue

      high = 1
      message.append("%s (%s) is %s full -- %s of %s used, %s remain\n" %
--- 295,304 ----
          continue

      if cutoff.has_key(volume):
!         if (nPct < long(cutoff[volume])): continue
      elif cutoff.has_key(mountpt):
!         if (nPct < long(cutoff[mountpt])): continue
!     elif (nPct < long(conf['defaultCutoff'])): continue

      high = 1
      message.append("%s (%s) is %s full -- %s of %s used, %s remain\n" %


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Tested on RedHat 7.3
2.Tested on Redhat 8.0
3.
    

Actual Results:  Falis to produce report

Expected Results:  Should have sent me a message indicating that disk is full.

Additional info:

If this is a real bug, please send thany you message to people who helped me to
prepare this bug report:

Dave, ds@es.usyd.edu.au
Danny, danny@anatomy.usyd.edu.au

Comment 1 Harald Hoyer 2003-05-09 12:41:49 UTC

*** This bug has been marked as a duplicate of 73335 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.