Bug 733432 - python-pygments is dragging in python26
Summary: python-pygments is dragging in python26
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-pygments
Version: el5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Milner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 733612 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 17:19 UTC by Toshio Ernie Kuratomi
Modified: 2011-10-01 01:33 UTC (History)
3 users (show)

Fixed In Version: python-pygments-1.4-3.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-01 01:33:29 UTC


Attachments (Terms of Use)

Description Toshio Ernie Kuratomi 2011-08-25 17:19:22 UTC
Description of problem:

The recent update that added a python26 subpackage has dependencies on python26 in the main package as well as the python26 subpackage.  This is leading to python-pygments dragging in python26.

Version-Release number of selected component (if applicable):
python-pygments-1.4-1.el5

How reproducible:
Every time

Steps to Reproduce:
1.rpm -q --requires python-pygments
2.
3.
  
Actual results:
/usr/bin/python  
python(abi) = 2.4
python(abi) = 2.6
python-imaging  
python-setuptools  
python26-distribute  
python26-imaging  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

Expected results:
No python(abi) = 2.6, python26-distribute, python26-imaging  in the output


Additional info:

The problem is in this section of the spec file:


%if 0%{?with_python26}
BuildRequires:  python26-devel, python26-distribute
Requires:       python26-distribute, python26-imaging
Requires:       python(abi) = 2.6
%endif


It should be:


%if 0%{?with_python26}
BuildRequires:  python26-devel, python26-distribute
%endif


The Requires that were here should instead go here:

%package -n python26-pygments
Summary:        A syntax highlighting engine written in Python 2.6
Group:          Development/Libraries
Requires:       python26-distribute
Requires:       python26-imaging
Requires:       python(abi) = 2.6

(Note that I'm not sure that python(abi) is needed there -- rpmbuild may well detect that automatically.)

Comment 1 Toshio Ernie Kuratomi 2011-08-26 12:31:10 UTC
*** Bug 733612 has been marked as a duplicate of this bug. ***

Comment 2 Toshio Ernie Kuratomi 2011-09-06 04:05:04 UTC
If you don't  have time to work on this but don't mind me fiddling with it, i'd be happy to apply the change and build new packages for epel5.  Just let me know.

Comment 3 Steve Milner 2011-09-09 20:22:24 UTC
Toshio,

Go for it! :-)

Comment 4 Fedora Update System 2011-09-13 00:55:45 UTC
python-pygments-1.4-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python-pygments-1.4-2.el5

Comment 5 Toshio Ernie Kuratomi 2011-09-13 02:05:20 UTC
I've fixed this but in the process discovered that the module is not being byte compiled properly.  Exploring this with dmalcolm, we could come up with no solution that would properly byte compile both the python26 and the python(2.4) module.  I'd recommend removing the python26 subpackage and submitting it as its own package.

Comment 6 Toshio Ernie Kuratomi 2011-09-13 16:31:30 UTC
Thanks to Jeffrey Ness, I've implemented a fix for byte compilation that also simplifies the spec file.  I'll issue it as a new update in a moment.

Comment 7 Fedora Update System 2011-09-13 17:36:39 UTC
python-pygments-1.4-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python-pygments-1.4-3.el5

Comment 8 Fedora Update System 2011-09-14 00:28:34 UTC
Package python-pygments-1.4-3.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-pygments-1.4-3.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/python-pygments-1.4-3.el5
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2011-10-01 01:33:25 UTC
python-pygments-1.4-3.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.