Bug 733612 - Latest update forces installation of python26
Summary: Latest update forces installation of python26
Keywords:
Status: CLOSED DUPLICATE of bug 733432
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-pygments
Version: el5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Milner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-26 09:14 UTC by Andrew Colin Kissa
Modified: 2011-08-26 12:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-26 12:31:10 UTC


Attachments (Terms of Use)

Description Andrew Colin Kissa 2011-08-26 09:14:11 UTC
Description of problem:The latest update introduced by https://bugzilla.redhat.com/show_bug.cgi?id=662755 breaks support for using python-pygments with python2.4 which comes with base, forcing the user to install python26 from epel even if they are not interested in having a dual python installation


Version-Release number of selected component (if applicable):1.4.1


How reproducible:yum install python-pygments

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.ufs.ac.za
 * epel: mirror.bytemark.co.uk
 * extras: mirror.ufs.ac.za
 * updates: mirror.ufs.ac.za
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package python-pygments.noarch 0:1.4-1.el5 set to be updated
--> Processing Dependency: python(abi) = 2.6 for package: python-pygments
--> Processing Dependency: python26-imaging for package: python-pygments
--> Processing Dependency: python26-distribute for package: python-pygments
--> Running transaction check
---> Package python26.x86_64 0:2.6.5-6.el5 set to be updated
--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: python26
---> Package python26-distribute.noarch 0:0.6.10-4.el5 set to be updated
---> Package python26-imaging.x86_64 0:1.1.7-4.el5 set to be updated
--> Running transaction check
---> Package python26-libs.x86_64 0:2.6.5-6.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================================================
 Package                                            Arch                                  Version                                     Repository                           Size
================================================================================================================================================================================
Installing:
 python-pygments                                    noarch                                1.4-1.el5                                   epel                                1.3 M
Installing for dependencies:
 python26                                           x86_64                                2.6.5-6.el5                                 epel                                6.5 M
 python26-distribute                                noarch                                0.6.10-4.el5                                epel                                510 k
 python26-imaging                                   x86_64                                1.1.7-4.el5                                 epel                                478 k
 python26-libs                                      x86_64                                2.6.5-6.el5                                 epel                                692 k

Transaction Summary
================================================================================================================================================================================
Install       5 Package(s)
Upgrade       0 Package(s)

Total size: 9.4 M
Is this ok [y/N]: 


Steps to Reproduce:
1. yum install python-pygments
2.
3.
  
Actual results:
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.ufs.ac.za
 * epel: mirror.bytemark.co.uk
 * extras: mirror.ufs.ac.za
 * updates: mirror.ufs.ac.za
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package python-pygments.noarch 0:1.4-1.el5 set to be updated
--> Processing Dependency: python(abi) = 2.6 for package: python-pygments
--> Processing Dependency: python26-imaging for package: python-pygments
--> Processing Dependency: python26-distribute for package: python-pygments
--> Running transaction check
---> Package python26.x86_64 0:2.6.5-6.el5 set to be updated
--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: python26
---> Package python26-distribute.noarch 0:0.6.10-4.el5 set to be updated
---> Package python26-imaging.x86_64 0:1.1.7-4.el5 set to be updated
--> Running transaction check
---> Package python26-libs.x86_64 0:2.6.5-6.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================================================
 Package                                            Arch                                  Version                                     Repository                           Size
================================================================================================================================================================================
Installing:
 python-pygments                                    noarch                                1.4-1.el5                                   epel                                1.3 M
Installing for dependencies:
 python26                                           x86_64                                2.6.5-6.el5                                 epel                                6.5 M
 python26-distribute                                noarch                                0.6.10-4.el5                                epel                                510 k
 python26-imaging                                   x86_64                                1.1.7-4.el5                                 epel                                478 k
 python26-libs                                      x86_64                                2.6.5-6.el5                                 epel                                692 k

Transaction Summary
================================================================================================================================================================================
Install       5 Package(s)
Upgrade       0 Package(s)

Total size: 9.4 M
Is this ok [y/N]: 


Expected results: It should not try and pull in python26, as pygments is supported by python24 which should be the default since it is supplied by
the base, packages in EPEL should not try replacing packages in base.


Additional info:

The spec file is broken, because python26 support should be in the python26-pygments package not in the python-pygments.

Comment 1 Andrew Colin Kissa 2011-08-26 09:23:28 UTC
Additional info:

rpm -q --requires -p python-pygments-1.4-1.el5.noarch.rpm 
/usr/bin/python  
python(abi) = 2.4
python(abi) = 2.6
python-imaging  
python-setuptools  
python26-distribute  
python26-imaging  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

Thats not right, it should not require any python26 packages.

Comment 2 Toshio Ernie Kuratomi 2011-08-26 12:31:10 UTC

*** This bug has been marked as a duplicate of bug 733432 ***


Note You need to log in before you can comment on or make changes to this bug.