Bug 733462 - glibc-2.14.90-6 causes kdeinit4 to segfault
glibc-2.14.90-6 causes kdeinit4 to segfault
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
: 733219 733514 733580 733800 (view as bug list)
Depends On:
Blocks: F16Blocker-kde
  Show dependency treegraph
 
Reported: 2011-08-25 14:35 EDT by Martin Kho
Modified: 2016-11-24 11:01 EST (History)
12 users (show)

See Also:
Fixed In Version: glibc-2.14.90-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-13 02:11:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kho 2011-08-25 14:35:03 EDT
Description of problem:
After the update to the above glibc the kde-desktop wont show up. In /var/log/message the following message appears:

"Aug 25 11:22:19 ps-1866 kernel: [  129.668398] kdeinit4[1021]: segfault at b0 ip 00007f9e60ddf2f1 sp 00007fff95741730 error 4 in libc-2.14.90.so[7f9e60cb8000+1a5000]"

Downgrading glibc (1.14.90-4) solves this issue.

Version-Release number of selected component (if applicable):
* glibc-2.14.90-6.x86_64
* kdelibs-4.7.0-1.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Log in into kde (plasma-desktop)
2. A message appears telling kdeinit4 can't be started
3.
  
Actual results:
No desktop

Expected results:
Desktop shows up

Additional info:
Comment 1 Rex Dieter 2011-08-25 14:46:37 EDT
to be clear, is prelinking enabled on this system?
Comment 2 Rex Dieter 2011-08-25 14:47:39 EDT
(tenatively putting on F16Blocker-kde ...)
Comment 3 Martin Kho 2011-08-25 15:56:13 EDT
Hi,

@comment 1: I've tried it on two F16 installs with the same result. One is an upgraded F15, the other is an updated F16 Alpha. For the first one I'm not 100% sure prelink is enabled, but for the second I'm rather sure it isn't, I would think? What is the default?

Hope this helps.

Martin Kho
Comment 4 Kevin Kofler 2011-08-25 17:34:21 EDT
Prelink is enabled by default.
Comment 5 José Matos 2011-08-26 07:24:33 EDT
I have prelinked enabled by default and I see the same for the two machines where I have upgraded to F16.
Comment 6 Martin Kho 2011-08-26 14:31:17 EDT
Hi,

I'm getting old :-) The same issue happened to my in 2009[1] (See also [2]) A work around was to run prelink -f /usr/bin/kdeinit4. This too, works for the current issue, at least for me.

Martin Kho

[1] https://bugzilla.redhat.com/show_bug.cgi?id=515539
[2] https://bugzilla.redhat.com/show_bug.cgi?id=519226
Comment 7 Rex Dieter 2011-08-26 14:51:08 EDT
If glibc is going to disavow this being a bug, perhaps we could put a %trigger in kdelibs to include that workaround on glibc upgrades...
Comment 8 Rex Dieter 2011-08-26 14:56:58 EDT
anyway, another test for regressions:

$ LD_BIND_NOW=1 /bin/ls

does this work ok?
Comment 9 José Matos 2011-08-26 15:00:47 EDT
(In reply to comment #8)
> anyway, another test for regressions:
> 
> $ LD_BIND_NOW=1 /bin/ls
> 
> does this work ok?

For me it does.
Comment 10 Martin Kho 2011-08-26 16:27:36 EDT
Yes, it does for me too.

Martin Kho
Comment 11 Andy Lawrence 2011-08-27 06:09:42 EDT
*** Bug 733800 has been marked as a duplicate of this bug. ***
Comment 12 Andreas Schwab 2011-08-29 05:50:30 EDT
*** Bug 733514 has been marked as a duplicate of this bug. ***
Comment 13 Andreas Schwab 2011-08-29 05:51:29 EDT
*** Bug 733219 has been marked as a duplicate of this bug. ***
Comment 14 Jan Safranek 2011-08-30 06:21:08 EDT
*** Bug 733580 has been marked as a duplicate of this bug. ***
Comment 15 Adam Williamson 2011-08-31 13:51:13 EDT
I'd say this isn't a blocker as -6 has actually been rejected through negative karma. The 'current' glibc build is now -4 again, that's what is in the repos and on composes, so this shouldn't affect any releases.
Comment 16 Fedora Update System 2011-09-02 03:18:39 EDT
glibc-2.14.90-7 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/glibc-2.14.90-7
Comment 17 Fedora Update System 2011-09-06 14:09:04 EDT
Package glibc-2.14.90-7:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.14.90-7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/glibc-2.14.90-7
then log in and leave karma (feedback).
Comment 18 Martin Kho 2011-09-07 09:15:17 EDT
Hi,

Yes, version -7 is working for me


Thanks,

Martin Kho
Comment 19 Fedora Update System 2011-09-08 16:48:11 EDT
Package glibc-2.14.90-8:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.14.90-8'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/glibc-2.14.90-8
then log in and leave karma (feedback).
Comment 20 Fedora Update System 2011-09-13 02:10:49 EDT
glibc-2.14.90-8 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.