Bug 515539 - kdeinit4: process for the fileprotocol / desktop protocol died unexpectedly
kdeinit4: process for the fileprotocol / desktop protocol died unexpectedly
Status: CLOSED DUPLICATE of bug 519226
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
: Reopened
: 517436 518638 519487 539555 (view as bug list)
Depends On:
Blocks: F12Blocker-kde
  Show dependency treegraph
 
Reported: 2009-08-04 13:19 EDT by Thomas Janssen
Modified: 2010-02-05 10:42 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-07 06:17:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
segfaults in /var/log/messages (1.11 KB, text/plain)
2009-08-05 10:03 EDT, Thomas Janssen
no flags Details
dmesg after removing prelink (40.16 KB, text/plain)
2009-08-14 06:00 EDT, Martin Kho
no flags Details

  None (edit)
Description Thomas Janssen 2009-08-04 13:19:01 EDT
Description of problem:
I have the default folder view plasmoid on the desktop. Every time i log in to kde i get "The process for the fileprotocol / desktop protocol died unexpectedly".

That affects as well: Dolphin and Konqueror (not able to get online as well). Browsing files is possible with Thunar for example.

Version-Release number of selected component (if applicable):
kdelibs-4.3.0-1.fc12.x86_64
kdelibs3-3.5.10-13.fc12.x86_64
kdelibs-experimental-4.3.0-1.fc12.x86_64

How reproducible:
Boot up and login to KDE

Steps to Reproduce:
1.
2.
3.
  
Actual results:
File and Desktop protocol dies unexpectedly. Therefore no filebrowsing possible.

Expected results:
Working File browsing.

Additional info:
Comment 1 Thomas Janssen 2009-08-05 10:03:39 EDT
Created attachment 356320 [details]
segfaults in /var/log/messages

Forgot that yesterday, sorry.
Comment 2 Martin Kho 2009-08-10 13:32:37 EDT
Hi,

This is a prelink issue. Every time a new glibc was released in rawhide I had to run: prelink -f /usr/bin/kdeinit4.

See also the post from sven on the fedora-kde list.

http://lists.fedoraproject.org/pipermail/fedora-kde/2009-July/003338.html

Hope this helps.

P.S. I thought this issue was already in bugzilla, but I can't find it. I'll first try a little harder.

Martin Kho
Comment 3 Thomas Janssen 2009-08-10 14:33:50 EDT
Yes, it worked indeed. I guess my prelink -a and prelink -ua runs were not that good as the prelink -f.

Thanks a lot Martin :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Rex Dieter 2009-08-12 16:17:53 EDT
Testing mmm, fresh F12-KDE-024 test image, same issue until manual run of 
prelink -f /usr/bin/kdeinit4

Adding as F12Blocker, we can't ship F12 kde spin this way.
Comment 5 Rex Dieter 2009-08-12 16:21:11 EDT
Maybe we could add /usr/bin/kdeinit4 to the prelink blacklist until this is sorted out?
Comment 6 Rex Dieter 2009-08-12 16:30:21 EDT
Nevermind, livecd ships with stuff not-yet-prelinked.

It *may* be affected by /etc/profile.d/kde4.sh that sets
KDE_IS_PRELINKED=1
if /etc/sysconfig/prelink contains
PRELINKING=yes

even if prelink hasn't run to actually *do* anything yet.

Suggestions?

Off the top of my head
1.  Don't ship prelink on kde live
2.  drop KDE_IS_PRELINKED hackage from kde4.(sh|csh)
...
4.  profit!
Comment 7 Rex Dieter 2009-08-12 16:31:26 EDT
for F12alpha, I'll see about temporarily omitting prelink, and we'll go from there.
Comment 8 Sebastian Vahl 2009-08-13 07:43:35 EDT
Can someone test this with the live image?

1. Boot the live image to runlevel 1
2. rpm -e prelink
3. remove the prelink lines from /etc/profile.d/kde4.(sh|csh)
4. init 5

This fixes the desktop protocol problem for me. But nm-applet won't connect to my router (which may be a temporary local problem of my router)
Comment 9 Rex Dieter 2009-08-13 07:54:39 EDT
I tested that myself, before suggesting it.  Worked for me.
Comment 10 Thomas Janssen 2009-08-13 08:01:25 EDT
Works for me.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Sebastian Vahl 2009-08-13 08:14:04 EDT
Ok. I'll remove prelink from the images then. I could also do the changes in /etc/profile.d/kde4.(sh|csh) on the live images as a workaround. But an updated kdelibs package would be better.
Comment 12 Rex Dieter 2009-08-13 19:09:15 EDT
*** Bug 517436 has been marked as a duplicate of this bug. ***
Comment 13 Orion Poplawski 2009-08-13 19:13:10 EDT
What about installed systems?
Comment 14 Rex Dieter 2009-08-13 19:32:34 EDT
OK, let's re-assign this back to kdelibs, until we have more evidence.

Orion, workarounds include 
1. See comment #4, and force re-prelinking of /usr/bin/kdeinit4
2. uninstalling prelink
3. edit /etc/sysconfig/prelink to include
PRELINKING=no
4. edit /etc/profile.d/kde4.*
to drop the stanza's referencing KDE_IS_PRELINKED
Comment 15 Martin Kho 2009-08-14 05:59:58 EDT
Hi,

Yes, the workaround works for me. But I get a segmentation fault in klauncher and kded4 (see comment #15: dmesg_noprelink) It has no negative effects, though, as I could see.

Martin

P.S. /etc/sysconfig/prelink is removed in step 2, so no need to set PRELINKING=no :-)
Comment 16 Martin Kho 2009-08-14 06:00:45 EDT
Created attachment 357418 [details]
dmesg after removing prelink
Comment 17 Martin Kho 2009-08-14 06:02:02 EDT
see comment #15 in comment #15 must be comment #16 :-)
Comment 18 Rex Dieter 2009-08-14 07:47:05 EDT
my comment only mentioned available workarounds, I didn't suggest doing *all* of them. :)

Anyway, if doing any of those, you still experience problems, then it's likely a spearate issue, please file a separate bug.  Thanks.
Comment 19 Rex Dieter 2009-08-14 10:21:34 EDT
kdelibs  %changelog
* Fri Aug 14 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.0-3
- kde4.(sh|csh): drop KDE_IS_PRELINKED for now (workaround bug #515539)
Comment 20 darrell pfeifer 2009-08-14 13:03:34 EDT
I installed this update hoping it would solve

startkde: Starting up...
/usr/bin/startkde: line 321:  7771 Segmentation fault      LD_BIND_NOW=true kdeinit4 +kcminit_startup
startkde: Could not start kdeinit4. Check your installation.

It didn't fix the problem. I also ran 'prelink -ua' for fun but that didn't change the problem either. This is on today's rawhide.

I did find a magic incantation (that I can't remember) that managed to start the kde desktop from the gnome terminal, so it seems that most of kde will work.

Should I file this as a separate bug?
Comment 21 Robin Green 2009-08-21 09:04:35 EDT
*** Bug 518638 has been marked as a duplicate of this bug. ***
Comment 22 Robin Green 2009-08-21 09:06:54 EDT
(In reply to comment #20)

> Should I file this as a separate bug?  

I've already filed it (see previous comment). You need to use the workaround already posted for this bug, namely (as root)

prelink -f /usr/bin/kdeinit4
Comment 23 Martin Kho 2009-08-21 14:04:20 EDT
Hi,

After a glibc update august 20th it happened again. I had to run prelink -f /usr/bin/kdeinit4. kdelibs was also updated (version 4.3.0-5.fc12.x86_64) It looks that the workaround in comment #19 is just a temporary fix?

Martin Kho
Comment 24 Rex Dieter 2009-08-21 14:10:03 EDT
Arg, requires more testing then, we may have to bounce this back to prelink.
Comment 25 Dennis Gilmore 2009-08-24 17:18:49 EDT
just wanted to report that 

prelink -f /usr/bin/kdeinit4 

or 

prelink -ua 

or 

prelink -a

did not work for me. 

rpm -q glibc kdelibs prelink
glibc-2.10.90-14.x86_64
glibc-2.10.90-14.i686
kdelibs-4.3.0-5.fc12.x86_64
prelink-0.4.2-2.fc12.x86_64

is what i have
Comment 26 Kevin Kofler 2009-08-25 10:56:04 EDT
I think prelink just triggers or untriggers a random bug there.
Comment 27 Rex Dieter 2009-08-25 17:48:46 EDT
may be related to use of LD_BIND_NOW=true (bug #519081)
Comment 28 Martin Kho 2009-08-26 10:26:31 EDT
Yes Rex, I think you're right!

I tried running the official F12 Alpha (F12-Alpha-x86_64-Live-KDE.iso) in qemu-kvm. After installing prelink and running prelink -ua I could start kde. But kdeinit4 crashed. Next I changed "LD_BIND_NOW=true kdeinit4 +kcminit_startup" in startkde to "kdeinit4 +kcminit_startup" and it works. kdeinit4 didn't crash. Can this be the solution?

Martin Kho
Comment 29 Rex Dieter 2009-08-26 10:31:43 EDT
That's just another bandaid/workaround, I'm hoping that it's properly fixed in glibc-2.10.90-16 from bug #519081)
Comment 30 Rex Dieter 2009-08-26 15:54:07 EDT
*** Bug 519487 has been marked as a duplicate of this bug. ***
Comment 31 Darryl L. Pierce 2009-08-26 16:10:16 EDT
(In reply to comment #22)
> (In reply to comment #20)
> 
> > Should I file this as a separate bug?  
> 
> I've already filed it (see previous comment). You need to use the workaround
> already posted for this bug, namely (as root)
> 
> prelink -f /usr/bin/kdeinit4  

This has worked for me as well. This is on a freshly (installed 26 August 2009) installed Rawhide system.
Comment 32 Ngo Than 2009-08-31 05:40:53 EDT
the new glibc-2.10.90-17 is now available in rawhide. Could someone please test it? thanks
Comment 33 Martin Kho 2009-08-31 06:45:54 EDT
Got it yesterday as an update. It failed again. Sorry...

Martin Kho
Comment 34 Rex Dieter 2009-08-31 13:28:20 EDT
ok, bouncing back to prelink (though could be glibc or linker related, unsure).
Comment 35 Thomas Janssen 2009-08-31 14:57:15 EDT
Sorry, not fixed. Even worse, with the latest updates applied i got a console telling me that it cant start kdeinit4 and i should check my installation. After the prelink -f /usr/bin/kdeinit4 i got my Desktop back.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 36 Vladimir 2009-09-02 05:35:08 EDT
I upgraded from F11 to F12 and get this problem. I did upgrade before F12 alpha ISO released.

Using prelink /usr/bin/kdeinit4 helps me only when I disable selinux, i.e.
selinux=disabled in /etc/selinux/config.

Interesting to know that gnome can start without doing prelink.

I have glibc 2.10.90.17 from rawhide at the moment.
Comment 37 Martin Kho 2009-09-03 04:47:00 EDT
Hi,

Today glibc was updated (glibc-2.10.90-18.x86_64). Again the 'protocol died'. But to have a working 'temporary solution' the workaround in comment #19 has to be applied to /etc/profile.d/kde.sh and /etc/profile.d/kde.csh (kdelibs3-3.5.10-13.fc12.x86_64).

Martin Kho
Comment 38 Rex Dieter 2009-09-03 08:36:38 EDT
Ah, totally forgot about kdelibs3, I'd venture we could safely drop the KDE_IS_PRELINKED hack from there too, not many kde3 apps floating around these days.
Comment 39 Anton Guda 2009-09-05 04:11:42 EDT
It may be a more generic bug:

$ LD_BIND_NOW=1 /bin/ls
Segmentation fault

And I never use prelink (disabled).

$ LD_DEBUG=all LD_BIND_NOW=1 /bin/ls
.......

3964:     symbol=free;  lookup in file=/bin/ls [0]
      3964:     symbol=free;  lookup in file=/lib/librt.so.1 [0]
      3964:     symbol=free;  lookup in file=/lib/libselinux.so.1 [0]
      3964:     symbol=free;  lookup in file=/lib/libcap.so.2 [0]
      3964:     symbol=free;  lookup in file=/lib/libacl.so.1 [0]
      3964:     symbol=free;  lookup in file=/lib/libc.so.6 [0]
      3964:     binding file /lib/ld-linux.so.2 [0] to /lib/libc.so.6 [0]: normal symbol `free' [GLIBC_2.0]
      3964:
      3964:     calling init: /lib/libpthread.so.0
      3964:
Segmentation fault
Comment 40 Ngo Than 2009-09-07 06:17:19 EDT

*** This bug has been marked as a duplicate of bug 519226 ***
Comment 41 Rex Dieter 2010-02-05 10:42:37 EST
*** Bug 539555 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.