Bug 733541 - LVMError: lvdeactivate failed for LV.root: LV VG00.Fedora.Sys/LV.root in use: not deactivating
Summary: LVMError: lvdeactivate failed for LV.root: LV VG00.Fedora.Sys/LV.root in us...
Keywords:
Status: CLOSED DUPLICATE of bug 693095
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a52f1600492c4f463b9d1bdf7d1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-25 23:31 UTC by Lee Hearne
Modified: 2011-11-23 04:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-27 00:04:15 UTC


Attachments (Terms of Use)

Description Lee Hearne 2011-08-25 23:31:05 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.x86_64
product:        Fedora
reason:         LVMError: lvdeactivate failed for LV.root:   LV VG00.Fedora.Sys/LV.root in use: not deactivating
time:           Fri Aug 26 00:30:00 2011
version:        16-Alpha

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.6 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicelibs/lvm.py", line 400, in lvdeactivate
:    raise LVMError("lvdeactivate failed for %s: %s" % (lv_name, msg))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 2561, in _teardown
:    lvm.lvdeactivate(self.vg.name, self._name)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 758, in teardown
:    self._teardown(recursive=recursive)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 485, in execute
:    self.device.teardown()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 316, in processActions
:    action.execute(intf=self.intf)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 383, in doIt
:    self.devicetree.processActions()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 122, in turnOnFilesystems
:    anaconda.storage.doIt()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
:    self.anaconda.dispatch.go_forward()
:LVMError: lvdeactivate failed for LV.root:   LV VG00.Fedora.Sys/LV.root in use: not deactivating
:

Comment 1 Lee Hearne 2011-08-26 17:17:13 UTC
This error occurred while trying to overwrite a Fedora 15 install with the DVD iso of 16 alpha.  I chose the manual disk layout as I have two LV groups, one for /home, which I didn't want overwritten, and another spilt over /tmp; /usr; /var; and /. I have a separate partition for /boot on /dev/sda. All partitions were originally formatted to ext4 except home, which is ext3.  All partitions except home were marked to be formatted.

I've tried several time to install the alpha, trying different combinations of formatting partitions (just / and /boot for example), and leaving out the /home volume group.  I either get this error; a fatal error that doesn't give any option but to reboot; and on at least two occasions a duplicate of error #722952, which is marked as not a bug and doesn't get recorded.  

I've gone back to version 15 on that box for now, but happy to try again if more info is needed or a workaround comes to light.

Comment 2 Brian Lane 2011-08-27 00:04:15 UTC

*** This bug has been marked as a duplicate of bug 693095 ***


Note You need to log in before you can comment on or make changes to this bug.