Bug 733717 - mod snmp memory footprint grows over time
Summary: mod snmp memory footprint grows over time
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins
Version: 4.2
Hardware: x86_64
OS: Linux
high
low vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: 735407 736145 736146 736147 742386 742390 742391
TreeView+ depends on / blocked
 
Reported: 2011-08-26 15:22 UTC by Robert Buck
Modified: 2018-11-14 14:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 735407 769997 (view as bug list)
Environment:
Last Closed:


Attachments (Terms of Use)
diffs for code review plus supporting information (5.30 KB, text/plain)
2011-08-26 15:22 UTC, Robert Buck
no flags Details
valgrind log showing top leaks last (look for 65 MiB leak, 852k leaked blocks) (26.53 KB, text/plain)
2011-08-26 15:24 UTC, Robert Buck
no flags Details
nodeload test script used to reproduce (822 bytes, text/plain)
2011-08-26 15:25 UTC, Robert Buck
no flags Details

Description Robert Buck 2011-08-26 15:22:43 UTC
Created attachment 520108 [details]
diffs for code review plus supporting information

Description of problem:

 mod snmp under apache leaks lots of memory

How reproducible:

 100%

Steps to Reproduce:

 1. Set up apache + valgrind
 2. Set up node.js + nodeload
 3. Set up nodeload test script to create 10 mins / 10 million request load.
 4. Run apache + valgrind
 5. Run nodeload
 6. Stop apache after nodeload stops
 7. Analyse valgrind output
  
Actual results:

 65 MiB leak over 10 mins; 850k requests, approx 850k leaked blocks

Expected results:

 No leaked blocks per request.

Additional info:

 See attached for leak reports, diffs, test scripts, etc.

Comment 1 Robert Buck 2011-08-26 15:24:17 UTC
Created attachment 520109 [details]
valgrind log showing top leaks last (look for 65 MiB leak, 852k leaked blocks)

Comment 2 Robert Buck 2011-08-26 15:25:02 UTC
Created attachment 520110 [details]
nodeload test script used to reproduce

Comment 3 Robert Buck 2011-09-02 13:16:36 UTC
The final results using the patched libraries show no leaks after 10M requests:

==31157== LEAK SUMMARY:
==31157==    definitely lost: 226 bytes in 4 blocks
==31157==    indirectly lost: 0 bytes in 0 blocks
==31157==      possibly lost: 0 bytes in 0 blocks
==31157==    still reachable: 216 bytes in 2 blocks
==31157==         suppressed: 0 bytes in 0 blocks

Comment 4 Robert Buck 2011-09-29 12:13:06 UTC
This has been fixed already; unsure why it's still open. The patch has been applied to SVN.

Comment 5 Larry O'Leary 2011-09-29 15:09:09 UTC
Looks like the fix was committed to trunk as rev 11204

Comment 6 Mike Foley 2011-10-03 17:07:55 UTC
verified 10/3/2011 daily build.  functional test.

Comment 7 Mike Foley 2012-02-07 19:30:45 UTC
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Comment 8 Mike Foley 2012-02-07 19:30:47 UTC
marking VERIFIED BZs to CLOSED/CURRENTRELEASE


Note You need to log in before you can comment on or make changes to this bug.