Bug 733742 - debuginfo conflicts on libdb.so.debug
Summary: debuginfo conflicts on libdb.so.debug
Keywords:
Status: CLOSED DUPLICATE of bug 739639
Alias: None
Product: Fedora
Classification: Fedora
Component: db4
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-26 16:34 UTC by Mads Kiilerich
Modified: 2013-07-02 23:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-03 10:53:17 UTC


Attachments (Terms of Use)

Description Mads Kiilerich 2011-08-26 16:34:20 UTC
In f16+updates-testing these can be installed side by side:

db4-4.8.30-3.fc15.i686
libdb-5.2.28-2.fc16.i686

But
  debuginfo-install db4 libdb
gives
  file /usr/lib/debug/usr/lib/libdb.so.debug conflicts between attempted installs of libdb-debuginfo-5.2.28-2.fc16.i686 and db4-debuginfo-4.8.30-3.fc15.i686
  file /usr/lib/debug/usr/lib/libdb_cxx.so.debug conflicts between attempted installs of libdb-debuginfo-5.2.28-2.fc16.i686 and db4-debuginfo-4.8.30-3.fc15.i686
  file /usr/lib/debug/usr/lib/libdb_java.so.debug conflicts between attempted installs of libdb-debuginfo-5.2.28-2.fc16.i686 and db4-debuginfo-4.8.30-3.fc15.i686

- and that will for example prevent getting full debug symbols for Python

I guess db4 is a kind of -compat package and should move out of the primary namespace?

Comment 1 Petr Pisar 2012-04-03 10:53:17 UTC

*** This bug has been marked as a duplicate of bug 739639 ***


Note You need to log in before you can comment on or make changes to this bug.