Bug 739639 - The debuginfo packages of db4 and libdb are in conflict.
Summary: The debuginfo packages of db4 and libdb are in conflict.
Keywords:
Status: CLOSED DUPLICATE of bug 769152
Alias: None
Product: Fedora
Classification: Fedora
Component: db4
Version: 15
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 733742 787004 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 17:12 UTC by Egon Kastelijn
Modified: 2013-07-02 23:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-03 11:01:06 UTC


Attachments (Terms of Use)

Description Egon Kastelijn 2011-09-19 17:12:51 UTC
Description of problem:
The debuginfo packages of db4 and libdb are in conflict.

Version-Release number of selected component (if applicable):
db4 4.8.30-3.fc15  (fedora repo)
libdb 5.1.25-3.fc15  (updates repo)

How reproducible:
always

Steps to Reproduce:
1. debuginfo-install db4 libdb
2.
3.
  
Actual results:
# debuginfo-install db4 libdb
Loaded plugins: auto-update-debuginfo, fastestmirror, langpacks, presto, refresh-packagekit
enabling fedora-debuginfo
enabling rpmfusion-nonfree-debuginfo
enabling updates-debuginfo
enabling rpmfusion-free-updates-debuginfo
enabling rpmfusion-free-debuginfo
enabling rpmfusion-nonfree-updates-debuginfo
Determining fastest mirrors
fedora/metalink                                                                                                                                                                                                       |  31 kB     00:00     
updates/metalink                                                                                                                                                                                                      |  22 kB     00:00     
 * fedora: ftp.tudelft.nl
 * fedora-debuginfo: ftp.tudelft.nl
 * rpmfusion-free: mirror.nl.leaseweb.net
 * rpmfusion-free-debuginfo: mirror.nl.leaseweb.net
 * rpmfusion-free-updates: mirror.nl.leaseweb.net
 * rpmfusion-free-updates-debuginfo: mirror.nl.leaseweb.net
 * rpmfusion-nonfree: mirror.nl.leaseweb.net
 * rpmfusion-nonfree-debuginfo: mirror.nl.leaseweb.net
 * rpmfusion-nonfree-updates: mirror.nl.leaseweb.net
 * rpmfusion-nonfree-updates-debuginfo: mirror.nl.leaseweb.net
 * updates: ftp.tudelft.nl
 * updates-debuginfo: ftp.uni-koeln.de
fedora                                                                                                                                                                                                                | 4.2 kB     00:00     
fedora/primary_db                                                                                                                                                                                                     |  14 MB     00:17     
fedora/group                                                                                                                                                                                                          | 1.8 MB     00:02     
rpmfusion-free                                                                                                                                                                                                        | 3.3 kB     00:00     
rpmfusion-free/primary_db                                                                                                                                                                                             | 378 kB     00:00     
rpmfusion-free/group                                                                                                                                                                                                  | 9.8 kB     00:00     
rpmfusion-free-updates                                                                                                                                                                                                | 2.7 kB     00:00     
rpmfusion-free-updates/primary_db                                                                                                                                                                                     | 206 kB     00:00     
rpmfusion-nonfree                                                                                                                                                                                                     | 3.3 kB     00:00     
rpmfusion-nonfree/primary_db                                                                                                                                                                                          | 115 kB     00:00     
rpmfusion-nonfree/group                                                                                                                                                                                               | 4.7 kB     00:00     
rpmfusion-nonfree-updates                                                                                                                                                                                             | 2.7 kB     00:00     
rpmfusion-nonfree-updates/primary_db                                                                                                                                                                                  |  54 kB     00:00     
updates                                                                                                                                                                                                               | 4.7 kB     00:00     
updates/primary_db                                                                                                                                                                                                    | 4.6 MB     00:05     
updates/group                                                                                                                                                                                                         | 1.9 MB     00:02     
Checking for new repos for mirrors
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Could not find debuginfo for main pkg: libdb-5.1.25-3.fc15.i686
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package glibc-debuginfo-2.14-5.x86_64 already installed and latest version
Package yum-plugin-auto-update-debug-info-1.1.31-2.fc15.noarch already installed and latest version
--> Running transaction check
---> Package db4-debuginfo.x86_64 0:4.8.30-3.fc15 will be installed
---> Package libdb-debuginfo.x86_64 0:5.1.25-3.fc15 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================================================================================================
 Package                                                    Arch                                              Version                                                     Repository                                                    Size
=============================================================================================================================================================================================================================================
Installing:
 db4-debuginfo                                              x86_64                                            4.8.30-3.fc15                                               fedora-debuginfo                                             6.3 M
 libdb-debuginfo                                            x86_64                                            5.1.25-3.fc15                                               updates-debuginfo                                            9.2 M

Transaction Summary
=============================================================================================================================================================================================================================================
Install       2 Package(s)

Total size: 15 M
Installed size: 102 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  file /usr/lib/debug/usr/lib64/libdb.so.debug conflicts between attempted installs of db4-debuginfo-4.8.30-3.fc15.x86_64 and libdb-debuginfo-5.1.25-3.fc15.x86_64
  file /usr/lib/debug/usr/lib64/libdb_cxx.so.debug conflicts between attempted installs of db4-debuginfo-4.8.30-3.fc15.x86_64 and libdb-debuginfo-5.1.25-3.fc15.x86_64
  file /usr/lib/debug/usr/lib64/libdb_java.so.debug conflicts between attempted installs of db4-debuginfo-4.8.30-3.fc15.x86_64 and libdb-debuginfo-5.1.25-3.fc15.x86_64

Error Summary
-------------



Expected results:
A normal install of the debuginfo packages.

Additional info:
I did a "yum clean all" before.

Comment 1 Pierre-Antoine Roiron 2011-11-21 09:28:38 UTC
I confirm I can reproduce this bug too on a fresh 64bit f16 install.

Comment 2 Petr Pisar 2012-04-03 10:53:18 UTC
*** Bug 733742 has been marked as a duplicate of this bug. ***

Comment 3 Petr Pisar 2012-04-03 10:56:21 UTC
*** Bug 787004 has been marked as a duplicate of this bug. ***

Comment 4 Petr Pisar 2012-04-03 11:01:06 UTC

*** This bug has been marked as a duplicate of bug 769152 ***


Note You need to log in before you can comment on or make changes to this bug.