Bug 733772 - Exception during disc analysis
Summary: Exception during disc analysis
Keywords:
Status: CLOSED DUPLICATE of bug 728883
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: i386
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-26 19:28 UTC by A.J. Werkman
Modified: 2011-08-29 08:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-29 08:35:19 UTC


Attachments (Terms of Use)
The exception error report (42.96 KB, application/x-gzip)
2011-08-26 19:28 UTC, A.J. Werkman
no flags Details
traceback from description attachment tarball (231.20 KB, text/plain)
2011-08-29 08:34 UTC, Radek Vykydal
no flags Details

Description A.J. Werkman 2011-08-26 19:28:11 UTC
Created attachment 520129 [details]
The exception error report

Description of problem:
Exception in anaconda while looking for disc layout

Version-Release number of selected component (if applicable):
16-Alpha.RC5

How reproducible:
Error disappeared after blanking the firt and last 1024 byte of the harddisk.

Steps to Reproduce:
1. Start installation using netinst CD
2. Used repo= parameter  and configured static IPv6 network address
3. Proceed to the step where the harddisc is read
4. Exception occures
  
Actual results:
Exception occures

Expected results:
Show disc layout


Additional info:

Comment 1 Brian Lane 2011-08-27 00:26:20 UTC
Please switch to tty2 (ctrl-alt-f2) and attach the logs from /tmp/*log to this bug as individual plain/text files.

Comment 2 Radek Vykydal 2011-08-29 08:34:32 UTC
Created attachment 520316 [details]
traceback from description attachment tarball

anaconda 16.14.6 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/re.py", line 137, in match
    return _compile(pattern, flags).match(string)
  File "/usr/lib/python2.7/site-packages/pyanaconda/installclass.py", line 207, in archesEq
    if re.match("i.86", a) and re.match("i.86", b):
  File "/usr/lib/python2.7/site-packages/pyanaconda/installclass.py", line 212, in productUpgradable
    return self.productMatches(oldprod) and self.versionMatches(oldver) and archesEq(arch, productArch)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1524, in findExistingRootDevices
    anaconda.instClass.productUpgradable(arch, product, version):
  File "/usr/lib/python2.7/site-packages/pyanaconda/upgrade.py", line 81, in findRootParts
    upgradeany=flags.cmdline.has_key("upgradeany"))
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
    self.dir = self.steps[self.step].target(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
    self.dispatch()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
    self.anaconda.dispatch.go_forward()
TypeError: expected string or buffer

Local variables in innermost frame:
pattern: i.86
flags: 0
string: None

Comment 3 Radek Vykydal 2011-08-29 08:35:19 UTC

*** This bug has been marked as a duplicate of bug 728883 ***


Note You need to log in before you can comment on or make changes to this bug.