Bug 73381 - cursor keeps blinking in unfocused windows
cursor keeps blinking in unfocused windows
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: gtk2 (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
: 74948 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-03 17:16 EDT by Paul Wouters
Modified: 2007-04-18 12:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 12:28:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wouters 2002-09-03 17:16:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
- blinking cursor in non active windows (try looking at 5 blinking cursors)
- no more scrolling with shift-page updown
- no more auto scrolling on selecting more then a screen full of text when
  hoovering near window border
- unreadable fonts, unless selecting huge fonts
- no more hidden scrollbar option

but it did fix a nasty bug with superlong lines and weird char sets
displaying completely wrong (overlapping on the same line)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use gnome-terminal with the things I said above.


Additional info:

I guess this is because this gnome-terminal is a completely different
package from the original gnome-terminal. We're getting into a
xterm versues rxvt war again all over :(

new features good: removing old features bad. If I could trade in tabs
for the old functionality, I would.
Comment 1 Havoc Pennington 2002-09-03 17:39:16 EDT
> blinking cursor in non active windows (try looking at 5 blinking cursors)

just a bug. 

> no more scrolling with shift-page updown

works for me? in what context are you trying it? do you have Shift+pageup 
bound to some other key in edit->keybindings?

> no more auto scrolling on selecting more then a screen full of text when
> hoovering near window border

fixed with newer vte package.

> unreadable fonts, unless selecting huge fonts

works for me. you may have an older version of vte or some of the font
packages. LucidaTypewriter is a good font to use.

> no more hidden scrollbar option

yes there is. It's on the Scrolling tab.

(for future reports, please try to file one issue per bug - otherwise 
we can't assign each task to different people/components, or close issues in 
different ways. for example the cursor blink issue goes to gnome-terminal, the
font issue goes to the font packages, and the rest on vte probably - different
people would address each of those.)
Comment 2 Joe Orton 2002-09-18 06:19:31 EDT
The "cursor keeps blinking" bug is present in gnome-terminal-2.0.1-5.  A
reproduction recipe seems to be:

1. focus on a gnome-terminal
2. press and hold alt-tab; *do not release*
3. click a window with the mouse outside the alt-tab switcher

The new window then gets the focus, but the original gnome-terminal still has a
blinking cursor.
Comment 3 Havoc Pennington 2002-09-18 11:09:50 EDT
This turned out to be a GTK bug
Comment 4 Owen Taylor 2002-09-18 12:16:22 EDT
It's been fixed in CVS, will make itelf into a release eventually.
Comment 5 Owen Taylor 2003-01-07 12:38:20 EST
This is 99% fixed in GTK+-2.2.0, but I've seen it happen to me once 
since I did the last bit of fixing a month or so ago, so it apparently
isn't 100% fixed...
Comment 6 Owen Taylor 2003-01-14 16:41:30 EST
*** Bug 74948 has been marked as a duplicate of this bug. ***
Comment 7 Owen Taylor 2003-08-28 12:28:54 EDT
Upstream bug for this is:

 http://bugzilla.gnome.org/show_bug.cgi?id=109246

Note You need to log in before you can comment on or make changes to this bug.