Bug 733863 - Unlocking file system during boot broken
Summary: Unlocking file system during boot broken
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-27 20:47 UTC by Jan Vlug
Modified: 2011-09-07 18:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-07 18:49:53 UTC


Attachments (Terms of Use)

Description Jan Vlug 2011-08-27 20:47:00 UTC
Description of problem:
I did an upgrade from Fedora 14 to Fedora 15 using preupgrade.
When the Fedora 15 2.6.40.3-0.fc15.x86_64 kernel is now booted, I get this error:

modprobe: FATAL: Could not load /lib/modules/2.6.40.3-0.fc15.x86_64/modules.dep: No such file or directory

device mapper: reload ioctl failed: Invalid argument
Failed to setup dm-crypt key mapping for device /dev/sda2.
Check that the kernel supports aes-xts-plain64 cipher (check syslog for more info).
Failed to read from key storage.

Then it is asking for the password for the encrypted disk:

Password for /dev/sda2 (luks-faa...):*******
When I enter the password I get:
[ 565.358082] device-mapper: table: 253:0: crypt: unknown target type

And then the modprobe message as above again, and the whole thing repeats.

Version-Release number of selected component (if applicable):
2.6.40.3-0.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1. Switch the laptop on

  
Actual results:
Repetitive request for file system password in text mode.

Expected results:
Request for file system password in a graphical window. After entering this, a normally booted system

Additional info:
Initially something went wrong with the preupgrade. I booted from a Fedora 15 DVD to 'rescue the system' and completed the upgrade with preupgrace-cli.
I tried to boot a remaining F14 kernel, but entering the file system passwords is half broken. I have to type letters several times before they appear (both in text and graphical mode). I think I manages once or twice to boot the system after the upgrade using a F14 kernel.

Comment 1 Jan Vlug 2011-08-28 18:15:47 UTC
Maybe these bugs are related:
Bug #712865 - Encrypted system fails to load
Bug #672848 - Unable to set password to unlock encrypted disk
Bug #698209 - Kernel panic - unable to mount root fs
Bug #716291 - Not all LUKS partitions are unlocked during boot process
Bug #708574 - Boot fails: Starting /home aborted because dependency failed
Bug #708456 - Need to disable plymouth to enter password for encrypted / and swap partitions
Bug #731261 - System does not boot, hangs on password request
Bug #732281 - System boot failed after creating new initramfs w/ initial distro kernel and other
Bug #589390 - aesni-intel module breaks booting off encrypted root

Comment 2 Jan Vlug 2011-08-30 17:53:18 UTC
I described the problem here as well:
http://forums.fedoraforum.org/showthread.php?t=268835

I can boot from an old Fedora 14 kernel (2.6.35.13-92.fc14.x86_64) if I remove the rgb boot parameter. Though I have to provide the file system password twice. And entering the second password goes difficult, because sometimes I have to hold the key pressed long before a '*' appears on the screen.

Comment 3 Jan Vlug 2011-09-07 18:49:53 UTC
I solved this problem by booting an old Fedora 14 kernel.
yum erase of the fedora 15 kernel.
yum install --releasever=15 of a new fedora 15 kernel.
After this the system booted without problems.


Note You need to log in before you can comment on or make changes to this bug.