Bug 734088 - postfix unable to open Berkeley db /etc/sasldb2: Invalid argument
Summary: postfix unable to open Berkeley db /etc/sasldb2: Invalid argument
Keywords:
Status: CLOSED DUPLICATE of bug 734084
Alias: None
Product: Fedora
Classification: Fedora
Component: postfix
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 12:34 UTC by Artur
Modified: 2011-08-29 12:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-29 12:41:51 UTC


Attachments (Terms of Use)

Description Artur 2011-08-29 12:34:02 UTC
Description of problem:

Users are unable to authenticate to smtp service. Postfix (smtpd) is uanble to access sasldb2 database via sasl library.

Version-Release number of selected component (if applicable): postfix-2.8.4-1.fc15

How reproducible: install postfix, configure it to use sasl authentication, configure sasl library for application smtpd to use pwcheck_method auxprop with plugin sasldb (the default), give postfix (smtpd) read access to /etc/sasldb2

Steps to Reproduce:
1. configure postfix to allow smtp access from network
2. configure smtpd to use sasl authentication
3. configure email client to use this instalation for sending mail via SMTP with smtp authentication turned on

Actual results:
(in maillog):
postfix/smtpd[27873]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: Invalid argument

Expected results:
(in maillog):
postfix/smtpd[8609]: 003A520047: client=unknown[x.x.x.x], sasl_method=LOGIN, sasl_username=username


Additional info:

This happens because postfix executables are are linked with db4-4.8 instead of libdb-5.1, and /usr/lib64/sasl2/libsasldb.so.2.0.23 (package cyrus-sasl-lib-2.1.23-18.fc15) is linked with libdb-5.1

Comment 1 Artur 2011-08-29 12:41:51 UTC

*** This bug has been marked as a duplicate of bug 734084 ***


Note You need to log in before you can comment on or make changes to this bug.