Bug 734096 - live cd boot error message: failed to execute '/sbin/initqueue' ...: No such file or directory
live cd boot error message: failed to execute '/sbin/initqueue' ...: No such ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 744464 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-29 09:00 EDT by Mads Kiilerich
Modified: 2011-10-10 04:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: dracut-013-12.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-02 14:11:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (107.08 KB, text/plain)
2011-08-29 09:00 EDT, Mads Kiilerich
no flags Details
lsinitrd /media/live/syslinux/initrd0.img (121.88 KB, text/plain)
2011-08-29 12:29 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2011-08-29 09:00:55 EDT
Created attachment 520388 [details]
dmesg

When booting a f16+updates-testing live image I get

[   17.620676] udevd[657]: failed to execute '/sbin/initqueue' '/sbin/initqueue --settled --onetime --unique /sbin/dmsquash-live-root /dev/sdb': No such file or directory

dracut-013-4.fc16.noarch
systemd-34-1.fc16.x86_64
Comment 1 Harald Hoyer 2011-08-29 11:42:13 EDT
what is the output of:

# lsinitrd <livecd initrd.img>
Comment 2 Mads Kiilerich 2011-08-29 12:29:54 EDT
Created attachment 520427 [details]
lsinitrd /media/live/syslinux/initrd0.img

It is not in the initrd created for the live cd - see the attached output.

I can however confirm that it exists in a corresponding initrd for an 'ordinary' system with the same package versions.

The live initrd was build with /etc/sysconfig/mkinitrd :

LIVEOS="yes"
PROBE="no"
MODULES+="squashfs ext4 ext3 ext2 vfat msdos "
MODULES+="sr_mod sd_mod ide-cd cdrom =ata sym53c8xx aic7xxx ehci_hcd uhci_hcd ohci_hcd usb_storage usbhid firewire-sbp2 firewire-ohci sbp2 ohci1394 ieee1394 mmc_block sdhci sdhci-pci pata_pcmcia mptsas udf virtio_blk virtio_pci "

- but I don't know if that could play any role ... or what controls how/when the iniqueue creation script is called.

I noticed
  /sbin/lsinitrd: line 27: file: command not found
when I ran lsinitrd - which is true. It is a minimal live cd and no packages required 'file'. I do however not see any indication that that can explain why iniqueue isn't created.
Comment 3 Harald Hoyer 2011-08-29 14:13:14 EDT
lrwxrwxrwx   1 root     root           18 Aug 29 11:08 sbin -> run/initramfs/sbin
-rwxr-xr-x   1 root     root         1131 Aug 12 14:17 run/initramfs/sbin/initqueue
Comment 4 Harald Hoyer 2011-08-29 14:15:31 EDT
lrwxrwxrwx   1 root     root            4 Aug 29 11:08 run/initramfs/bin/sh -> dash
-rwxr-xr-x   1 root     root       106872 May 23 07:22 run/initramfs/bin/dash

Hmm... this really should work.
Comment 5 Harald Hoyer 2011-08-29 14:19:26 EDT
ooooooh... 

[   11.440251] dracut: Switching root
[   17.620676] udevd[657]: failed to execute '/sbin/initqueue' '/sbin/initqueue --settled --onetime --unique /sbin/dmsquash-live-root /dev/sdb': No such file or directory

Huh?? How could that happen? We are not in the dracut initramfs anymore and we have udev rules from the initramfs still floating around....

Let me have a close look!
Comment 6 Harald Hoyer 2011-08-29 14:23:01 EDT
You don't happen to have "/etc/udev/rules.d/99-liveiso-mount.rules" in your live-CD root?
Comment 7 Mads Kiilerich 2011-08-29 15:06:47 EDT
No 99-liveiso-mount.rule anywhere. Also no 99-live-squash.rules.

Do the old initramfs udev and all children die silently when the real udev starts?
Comment 8 Mads Kiilerich 2011-08-29 15:31:12 EDT
The live system do have /run/udev/rules.d/99-live-squash.rules and /run/initramfs/sbin/initqueue .
Comment 9 Harald Hoyer 2011-08-29 17:55:09 EDT
can you upload the .iso somewhere for me to inspect it?
Comment 10 Mads Kiilerich 2011-08-29 18:13:20 EDT
I assume the latest isos from http://alt.fedoraproject.org/pub/alt/nightly-composes/ can be used - I will verify that tomorrow.
Comment 11 Mads Kiilerich 2011-08-30 10:03:39 EDT
Reproduced with Fedora-16-Nightly-20110828.10-x86_64-Live-desktop.iso from http://alt.fedoraproject.org/pub/alt/nightly-composes/
- livecd-iso-to-disk'ed and booted with enforcing=0
Comment 12 Fedora Update System 2011-09-20 04:58:49 EDT
dracut-013-10.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dracut-013-10.fc16
Comment 13 Fedora Update System 2011-09-20 10:32:59 EDT
dracut-013-11.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dracut-013-11.fc16
Comment 14 Fedora Update System 2011-09-20 15:05:42 EDT
Package dracut-013-11.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-013-11.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/dracut-013-11.fc16
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2011-09-21 12:38:06 EDT
dracut-013-12.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dracut-013-12.fc16
Comment 16 Fedora Update System 2011-10-02 14:11:42 EDT
dracut-013-12.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Harald Hoyer 2011-10-10 04:46:49 EDT
*** Bug 744464 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.