Bug 734208 - Rebase hivex in RHEL 6.3
Summary: Rebase hivex in RHEL 6.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hivex
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 751043 (view as bug list)
Depends On:
Blocks: libguestfs_rebase6.3 756082
TreeView+ depends on / blocked
 
Reported: 2011-08-29 18:24 UTC by Richard W.M. Jones
Modified: 2012-06-20 12:22 UTC (History)
5 users (show)

Fixed In Version: hivex-1.3.3-4.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of: 719877
Environment:
Last Closed: 2012-06-20 12:22:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0776 normal SHIPPED_LIVE hivex bug fix and enhancement update 2012-06-19 20:35:06 UTC

Description Richard W.M. Jones 2011-08-29 18:24:21 UTC
hivex has a small number of bug fixes between 1.2.4 (in RHEL 6)
and the latest upstream 1.3.1.  See:

http://git.annexia.org/?p=hivex.git;a=shortlog

Upstream we take backwards compatibility very seriously, so there
should be no API or ABI regressions caused by this rebase.

The alternative is maintaining a package with ~40 patches.

Comment 2 Richard W.M. Jones 2011-11-03 14:38:06 UTC
*** Bug 751043 has been marked as a duplicate of this bug. ***

Comment 3 Richard W.M. Jones 2011-12-06 08:34:44 UTC
http://people.redhat.com/~rjones/libguestfs-RHEL-6.3-preview/

Note these packages are NOT supported by Red Hat.

Comment 6 Mohua Li 2012-05-22 09:01:14 UTC
all bugs verified in hivex 6.3 errata.

Comment 8 errata-xmlrpc 2012-06-20 12:22:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0776.html


Note You need to log in before you can comment on or make changes to this bug.