Bug 734273 - Missing /etc/tmpfiles.d/ddclient.conf file
Summary: Missing /etc/tmpfiles.d/ddclient.conf file
Keywords:
Status: CLOSED DUPLICATE of bug 656572
Alias: None
Product: Fedora
Classification: Fedora
Component: ddclient
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 753714 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 00:20 UTC by Martí­n Marqués
Modified: 2012-05-15 15:18 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 15:18:51 UTC


Attachments (Terms of Use)
Add /var/run/ddclient directory creation to tmpfiles (2.27 KB, patch)
2011-11-21 12:28 UTC, Juan Orti Alcaine
no flags Details | Diff
Add /var/run/ddclient directory creation to tmpfiles (2.07 KB, patch)
2011-11-24 12:06 UTC, Juan Orti Alcaine
no flags Details | Diff
Add /var/run/ddclient directory creation to tmpfiles (2.14 KB, patch)
2011-11-24 15:07 UTC, Juan Orti Alcaine
no flags Details | Diff

Description Martí­n Marqués 2011-08-30 00:20:37 UTC
Description of problem:

Missing /etc/tmpfiles.d/ddclient.conf file

Version-Release number of selected component (if applicable):

# rpm -q ddclient
ddclient-3.8.0-4.fc15.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

/var/run/ddclient doesn't exist, and ddclient can't put it's .pid file.

Expected results:


Additional info:

Comment 1 Juan Orti Alcaine 2011-11-21 12:25:59 UTC
I'm experiencing the same problem with Fedora 16 x86_64 and ddclient-3.8.0-4.fc15.noarch

I attach a patch that solves the problem.

Comment 2 Juan Orti Alcaine 2011-11-21 12:28:35 UTC
Created attachment 534770 [details]
Add /var/run/ddclient directory creation to tmpfiles

Comment 3 Juan Orti Alcaine 2011-11-21 12:31:42 UTC
Comment on attachment 534770 [details]
Add /var/run/ddclient directory creation to tmpfiles

>commit b9eae9dc17cd72914e374e831f77af146415524e
>Author: Juan Orti Alcaine <j.orti.alcaine@gmail.com>
>Date:   Mon Nov 21 13:21:23 2011 +0100
>
>    Add /var/run/ddclient directory creation to tmpfiles. Fix bug #734273
>
>diff --git a/ddclient.spec b/ddclient.spec
>index c660cf2..6a03bfd 100644
>--- a/ddclient.spec
>+++ b/ddclient.spec
>@@ -1,7 +1,7 @@
> Summary:           Client to update dynamic DNS host entries
> Name:              ddclient
> Version:           3.8.0
>-Release:           4%{?dist}
>+Release:           5%{?dist}
> License:           GPLv2+
> Group:             System Environment/Daemons
> URL:               http://ddclient.sourceforge.net/
>@@ -10,6 +10,7 @@ Source1:           ddclient.rwtab
> Source2:           ddclient.initscript
> Source3:           ddclient.sysconfig
> Source4:           ddclient.NetworkManager
>+Source5:           ddclient.tmpfiles

> BuildArch:         noarch
> Requires(pre):     shadow-utils
> Requires(post):    /sbin/chkconfig
>@@ -54,6 +55,7 @@ install -p -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
> mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d
> install -p -m 755 %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d/50-%{name}
> %endif
>+install -p -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/%{name}.conf
> mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/{cache,run}/%{name}
> touch $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name}/%{name}.cache
> 
>@@ -91,6 +93,7 @@ fi
> %if 0%{?fedora}%{?rhel} > 4
> %{_sysconfdir}/NetworkManager/dispatcher.d/50-%{name}
> %endif
>+%{_sysconfdir}/tmpfiles.d/%{name}
> %attr(600,%{name},%{name}) %config(noreplace) %{_sysconfdir}/%{name}.conf
> %config(noreplace) %{_sysconfdir}/rwtab.d/%{name}
> %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
>@@ -100,6 +103,9 @@ fi
> %attr(0755,%{name},%{name}) %dir %{_localstatedir}/run/%{name}/
> 
> %changelog
>+* Mon Nov 21 2011 Juan Orti Alcaine <j.orti.alcaine@gmail.com> 3.8.0-5
>+- Add /var/run/ddclient directory creation to tmpfiles
>+
> * Thu Feb 10 2011 Robert Scheck <robert@fedoraproject.org> 3.8.0-4
> - Replaced Requires(hint) by Requires as RPM 4.9 dropped support
> 
>diff --git a/ddclient.tmpfiles b/ddclient.tmpfiles
>new file mode 100644
>index 0000000..c9c73c7
>--- /dev/null
>+++ b/ddclient.tmpfiles
>@@ -0,0 +1 @@
>+d /var/run/ddclient   755 ddclient ddclient

Comment 4 Juan Orti Alcaine 2011-11-21 12:34:42 UTC
Sorry for pasting the patch here, I forgot to rename the file as /etc/tmpfiles.d/ddclient.conf

Comment 5 Juan Orti Alcaine 2011-11-24 12:06:06 UTC
Created attachment 535874 [details]
Add /var/run/ddclient directory creation to tmpfiles

Comment 6 Juan Orti Alcaine 2011-11-24 15:07:56 UTC
Created attachment 535948 [details]
Add /var/run/ddclient directory creation to tmpfiles

Fix previous patch by creating the tmpfiles.d directory in the buildroot

Comment 7 Trever Adams 2012-01-31 22:08:18 UTC
This also affects ddclient in Fedora 16. With the changes to systemd recently, without a proper /etc/tmp.d/ddclient.conf boot hangs.

Comment 8 Trever Adams 2012-01-31 22:08:28 UTC
*** Bug 753714 has been marked as a duplicate of this bug. ***

Comment 9 David Rees 2012-02-19 17:52:02 UTC
This is a show stopper.  Took me forever to figure out why my F16 system was hanging on boot.  Any chance of getting at least an updates package with this fix?

Comment 10 Ioannis Aslanidis 2012-03-08 00:01:09 UTC
I am suffering the same issue with ddclient. Can someone please explain what is the workaround for F16?

Comment 11 Ioannis Aslanidis 2012-03-08 00:05:58 UTC
I checked and /var/run/client does exist in F16:

drwxr-xr-x. 2 ddclient ddclient 40 Mar  8 00:49 /var/run/ddclient

Yet, I get the same error as described in Bug 753714:

systemd[1]: PID file /var/run/ddclient/ddclient.pid not readable (yet?) after start.
systemd[1]: Unit ddclient.service entered failed state.

I have disabled SELinux to check whether there was a permission problem, but it kept on failing. Running ddclient manually does work properly.

Any clues anyone?

Comment 12 Ioannis Aslanidis 2012-03-08 00:07:12 UTC
Sorry, I meant to say Bug 781526 in Comment 11.

Comment 13 Ken Kolden 2012-03-13 03:31:07 UTC
(In reply to comment #10)
> I am suffering the same issue with ddclient. Can someone please explain what is
> the workaround for F16?

create /etc/tmpfiles.d/ddclient.conf

containing line

d /var/run/ddclient 0755 ddclient ddclient -

Comment 14 Martí­n Marqués 2012-03-15 12:25:20 UTC
Why can't that file be added to the ddclient package? Who is the ddclient packager?

Comment 15 Jonathan Kamens 2012-05-15 15:18:51 UTC

*** This bug has been marked as a duplicate of bug 656572 ***


Note You need to log in before you can comment on or make changes to this bug.