This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 656572 - Please Update Spec File to use %ghost on files in /var/run and /var/lock
Please Update Spec File to use %ghost on files in /var/run and /var/lock
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ddclient (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
http://lists.fedoraproject.org/piperm...
:
: 734273 781526 814907 819487 (view as bug list)
Depends On:
Blocks: 827166
  Show dependency treegraph
 
Reported: 2010-11-23 18:27 EST by Lennart Poettering
Modified: 2012-08-18 22:37 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 03:42:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
create /var/run/ddclient as needed in init script (633 bytes, patch)
2011-07-07 10:22 EDT, Jonathan Kamens
no flags Details | Diff
create /var/run/ddclient as needed on install (329 bytes, patch)
2012-08-18 22:33 EDT, John Minkle
no flags Details | Diff

  None (edit)
Description Lennart Poettering 2010-11-23 18:27:31 EST
Your package ddclient appears to include a file in /var/run or /var/lock. With an upcoming change in Rawhide these directories will now be mounted as tmpfs. For details about this change please consult http://lists.fedoraproject.org/pipermail/devel-announce/2010-November/000726.html For your package this means that you need add %ghost to all files that are placed in either of these two directories. Please make sure to make this change in time for the F15 cycle. For details about %ghost see http://www.rpm.org/max-rpm-snapshot/s1-rpm-inside-files-list-directives.html#S3-RPM-INSIDE-FLIST-GHOST-DIRECTIVE , for more information on the F15 feature see the feature page https://fedoraproject.org/wiki/Features/var-run-tmpfs . If your package already uses %ghost on these files, feel free to close this bug report right-away. Sorry for this mass bug filing, and if you have any further questions, don't hesitate to ask on fedora-devel or ask me personally. Thank you, Lennart
Comment 1 Henrique Martins 2011-05-29 10:27:14 EDT
Fedora 15 is here and breaks ddclient's ability to create /var/run/ddclient/ddclient.pid, as described above.  I believe this is an issue with Fedora packaging.  If not I'll file a bug at the sourceforge tracker for ddclient.
Comment 2 Jonathan Kamens 2011-07-07 10:22:33 EDT
Created attachment 511722 [details]
create /var/run/ddclient as needed in init script
Comment 3 Ken Kolden 2012-01-31 23:14:55 EST
Duplicate of Bug 734273
Comment 4 Jonathan Kamens 2012-05-15 11:18:51 EDT
*** Bug 734273 has been marked as a duplicate of this bug. ***
Comment 5 Jonathan Kamens 2012-05-15 11:19:58 EDT
*** Bug 781526 has been marked as a duplicate of this bug. ***
Comment 6 Jonathan Kamens 2012-05-15 11:22:00 EDT
*** Bug 814907 has been marked as a duplicate of this bug. ***
Comment 7 Jonathan Kamens 2012-05-15 11:22:32 EDT
*** Bug 819487 has been marked as a duplicate of this bug. ***
Comment 8 Jonathan Kamens 2012-05-15 11:26:48 EDT
I believe this is mostly fixed in ddclient-3.8.1-2.fc17, but it's still missing the %ghost declaration for /var/run/ddclient.
Comment 9 Fedora Update System 2012-05-15 11:39:56 EDT
ddclient-3.8.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ddclient-3.8.1-3.fc17
Comment 10 Fedora Update System 2012-05-26 03:42:01 EDT
ddclient-3.8.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 John Minkle 2012-08-18 21:07:21 EDT
installed ddclient-3.8.1-3.fc17 and ran systemctl start ddclient.service and get

WARNING:  Cannot create file '/var/run/ddclient/ddclient.pid'. (No such file
or directory)
Comment 12 John Minkle 2012-08-18 22:33:58 EDT
Created attachment 605448 [details]
create /var/run/ddclient as needed on install

this will properly create the /var/run/ddclient folder if needed

Note You need to log in before you can comment on or make changes to this bug.