Bug 73440 - Princonf backend errors when restarting lpd. Cannot configure printers
Princonf backend errors when restarting lpd. Cannot configure printers
Status: CLOSED DUPLICATE of bug 72177
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-printer (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-04 15:02 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-04 15:18:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-09-04 15:02:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
When attempting to start lpd I get the following error:
[root@et1 root]# service lpd restart
Stopping lpd:                                              [FAILED]
Starting lpd: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import printconf_backend
  File "/usr/share/printconf/util/printconf_backend.py", line 30, in ?
    _=gettext.gettext
NameError: name 'gettext' is not defined
No Printers Defined                                        [  OK  ]

Version-Release number of selected component (if applicable):
0.4.21-1

How reproducible:
Always

Steps to Reproduce:
1.use printconf-gui to configure Jetdirect print queues
2.apply changes and attempt test page.
3.use 'service lpd restart' as root in terminal and error print out.
	

Actual Results:  [root@et1 root]# service lpd restart
Stopping lpd:                                              [FAILED]
Starting lpd: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import printconf_backend
  File "/usr/share/printconf/util/printconf_backend.py", line 30, in ?
    _=gettext.gettext
NameError: name 'gettext' is not defined
No Printers Defined                                        [  OK  ]

Expected Results:  lpd should have restarted and my printers should have been
configured and queues created

Additional info:
Comment 1 Peter Lemieux 2002-09-04 15:18:36 EDT
I tried uninstalling redhat-config-printer and downgrading to
printconf-0.3.77-1.i386.rpm and LPRng-3.7.4-23, but I couldn't find a
combination from earlier releases that worked either.

Either I get the "gettext not defined" error, or a "no printers configured"
error depending on the combination I try.
Comment 2 Tim Waugh 2002-09-04 17:02:22 EDT
This is fixed in redhat-config-printer-0.4.22-1 and later. 

*** This bug has been marked as a duplicate of 72177 ***

Note You need to log in before you can comment on or make changes to this bug.