Bug 73468 - Anaconda gets the wrong DPI if you can't run X in 800x600
Anaconda gets the wrong DPI if you can't run X in 800x600
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
: 76122 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-04 21:23 EDT by Jonathan Blandford
Modified: 2013-04-02 00:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:57:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file of starting X (29.11 KB, patch)
2002-09-05 11:13 EDT, Jonathan Blandford
no flags Details | Diff
XF86Config file provided by anaconda (3.73 KB, patch)
2002-09-05 11:15 EDT, Jonathan Blandford
no flags Details | Diff

  None (edit)
Description Jonathan Blandford 2002-09-04 21:23:34 EDT
If X doesn't like either of the modes that anaconda provides in its XF86Config
file, then it will pick its own resolution.  As a result, the font size is too
big when anaconda starts.  When you finally reach the Install/Update screen, it
results in the radio buttons appearing behind the 'Back/Next' buttons, and
preventing you from clicking on them.  It has the added side-effect of making
the screen insensitive, making it look like you've gone forward and hung.

It would be good to pick a different DPI if the resolution given isn't the one
we expect.
Comment 1 Jeremy Katz 2002-09-04 22:11:55 EDT
To clarify -- we get confused when we explicitly put 800x600 as the resolution
in the config file, but X then decides "oh, I don't want you to do that" and
starts up in 1024x768 instead :/

Which means that our carefully calculated DisplaySize ends up being wrong (and
dpi is 123x123 or something along those lines)
Comment 2 Michael Fulbright 2002-09-04 22:55:18 EDT
See if we'd tried to hit 85 dpi like I said it would have still worked ok :)
Comment 3 Jonathan Blandford 2002-09-05 11:13:51 EDT
Created attachment 75045 [details]
Log file of starting X
Comment 4 Jonathan Blandford 2002-09-05 11:15:34 EDT
Created attachment 75046 [details]
XF86Config file provided by anaconda
Comment 5 Jonathan Blandford 2002-09-05 11:32:08 EDT
Attached logs from my install for posterities sake.

To change the DPI once we've imported gtk, we can just call:
gtk.rc_parse_string ("gtk-xft-dpi=12345")
Comment 6 Owen Taylor 2002-09-05 11:52:53 EDT
Note that 12345 is 1024*desired_dpi
Comment 7 Michael Fulbright 2002-10-31 15:44:01 EST
*** Bug 76122 has been marked as a duplicate of this bug. ***
Comment 8 Michael Fulbright 2002-11-13 15:29:10 EST
I should have this fixed now.
Comment 9 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated
Comment 10 Brent Fox 2003-05-25 10:57:47 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.