Bug 734849 - Changeset History page Refresh shows Tupane Error Page
Summary: Changeset History page Refresh shows Tupane Error Page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On: 734899
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-31 15:47 UTC by Eric Helms
Modified: 2013-08-16 18:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:54:48 UTC


Attachments (Terms of Use)

Description Eric Helms 2011-08-31 15:47:51 UTC
Description of problem: When viewing the details of a changeset on the changeset history page and then refreshing the page an error panel will appear in the tupane pop-out.


Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Click environment from selector that is not locker and has changesets listed.
2. Click changeset in left hand panel to open edit panel.
3. Refresh page.
  
Actual results:
Error panel appears in tupane popout with no changesets in the left hand list.

Expected results:
The same list of changesets should be visible with the same selected changeset and edit panel for that changeset.

Additional info:

Comment 1 Jason E. Rist 2011-09-07 18:46:03 UTC
This appears to be tied to the locker default bug (734899).

Comment 2 Justin Sherrill 2011-09-13 17:34:48 UTC
Should be fixed in master now:

f58882c2d2c3dfbcc36acd757695161e287f4a1b


Added javascript to make the right panel load wait until the left panel is done.

Comment 3 Corey Welton 2011-09-22 14:42:29 UTC
QA Verified.

Comment 6 Mike McCune 2013-08-16 18:11:30 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.