Bug 734899 - Changeset History: Cannot navigate back to locker changesets from other environments
Summary: Changeset History: Cannot navigate back to locker changesets from other envir...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 734849 katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-31 19:24 UTC by Corey Welton
Modified: 2013-08-16 18:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:55:03 UTC


Attachments (Terms of Use)

Description Corey Welton 2011-08-31 19:24:18 UTC
Description of problem:
In the Changeset History view, user can click one of the other user-created environments to view changesets that exist there.  However, trying to click Locker fails to take user back to that view. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a new environment, "Dev", in ACME_Corporation
2. Content Management > Promotions. 
3. Create a new changeset ("TestChangeset") and promote it to dev
4. Content Management > Changeset History; note that default environment is locker
5. Click "Dev" in the Environment path UI element, observing the correct promotion of your TestChangeset
6. Click Locker in the Environnment path UI element.
  
Actual results:
Locker never changes color
User cannot click through locker

Expected results:
User should be able to nav to Locker just like any other env.

Additional info:
Note: workaround is to simply do Content Management > Changeset History again, but that's still disjointed.  User should be able to traverse the environment paths.

Comment 1 Mike McCune 2011-09-02 19:13:11 UTC
you should never end up in the locker for changesets ...

Comment 2 Justin Sherrill 2011-09-13 17:33:37 UTC
This is now fixed in master :  01d22151a351ab75f68482c72e226f1abef41610


You should never be taken to locker on this page, except if locker is the only environment (and nothing would show up anyways).

Comment 3 Corey Welton 2011-09-22 14:04:14 UTC
QA Verified

Comment 6 Mike McCune 2013-08-16 18:03:41 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.