Bug 734854 - 'service katello-jobs status' does not work correctly when service is stopped.
Summary: 'service katello-jobs status' does not work correctly when service is stopped.
Keywords:
Status: CLOSED DUPLICATE of bug 734755
Alias: None
Product: Katello
Classification: Retired
Component: Packaging
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Mike McCune
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 16:02 UTC by Corey Welton
Modified: 2011-08-31 18:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-31 18:25:36 UTC


Attachments (Terms of Use)

Description Corey Welton 2011-08-31 16:02:44 UTC
Description:
When the katello-jobs status is not running, a status check returns a bunch of garbage to the terminal.


Steps to Reproduce:
1.  service katello-jobs start
2.  service katello-jobs status
3.  service katello-jobs stop
4.  service katello-jobs status

  
Actual results:

[root@core-01 pids]# service katello-jobs status
cat: : No such file or directory
ERROR: List of process IDs must follow -p.
********* simple selection *********  ********* selection by list *********
-A all processes                      -C by command name
-N negate selection                   -G by real group ID (supports names)
-a all w/ tty except session leaders  -U by real user ID (supports names)
-d all except session leaders         -g by session OR by effective group name
-e all processes                      -p by process ID
T  all processes on this terminal     -s processes in the sessions given
a  all w/ tty, including other users  -t by tty
g  OBSOLETE -- DO NOT USE             -u by effective user ID (supports names)
r  only running processes             U  processes for specified users
x  processes w/o controlling ttys     t  by tty
*********** output format **********  *********** long options ***********
-o,o user-defined  -f full            --Group --User --pid --cols --ppid
-j,j job control   s  signal          --group --user --sid --rows --info
-O,O preloaded -o  v  virtual memory  --cumulative --format --deselect
-l,l long          u  user-oriented   --sort --tty --forest --version
-F   extra full    X  registers       --heading --no-heading --context
                    ********* misc options *********
-V,V  show version      L  list format codes  f  ASCII art forest
-m,m,-L,-T,H  threads   S  children in sum    -y change -l format
-M,Z  security data     c  true command name  -c scheduling class
-w,w  wide output       n  numeric WCHAN,UID  -H process hierarchy
katello-job is not running.

Expected results:
Clean results.

Additional info:

Comment 1 Corey Welton 2011-08-31 18:25:36 UTC

*** This bug has been marked as a duplicate of bug 734755 ***


Note You need to log in before you can comment on or make changes to this bug.